Bug 145623 - Better dual boot support / automatic non-destructive NTFS resize
Better dual boot support / automatic non-destructive NTFS resize
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-19 23:47 EST by Christopher Beland
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 11:18:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2005-01-19 23:47:14 EST
Adding a flavor of Red Hat Linux to a computer that is already running
Windows is an operation that should be reliable and trouble-free.  If
Linux is to make substantial inroads into the desktop market, it must
be appealing to the existing base of Windows users, including and
especially ease of installation.  It's a much smaller leap of faith to
add a second operating system and dual-boot than it is to wipe a hard
drive clean and put all of one's trust in an untested and unfamiliar
operating system, even if you've heard good things about it.

Personally, my problem was that the laptop I bought came pre-installed
with Windows.  Reportedly the rescue disk it came can only restore the
system to its original state, not do a Windows install after
re-partitioning in preparation for dual-boot.  Though for many people,
their Windows partition will have lots of applications and data which
have accumulated over time, which it would be extremely annoying and
time-consuming to re-install from scratch.

The convenient solution when preparing for dual-boot on a machine that
already has Windows installed, is to defragment, resize the Windows
partition so it takes up half the disk instead of the whole thing, and
install Linux in the newly freed-up space.

Unfortunately, this procedure is currently very difficult to
implement, even though all the tools necessary to do so are reportedly
available.  Though fdisk and the parted included on the Fedora Core 3
Rescue CD can't resize NTFS partitions (which is the format Windows XP
comes pre-installed on), ntfsresize from
http://linux-ntfs.sourceforge.net/ can.

It took me more than a day of poking, prodding, and waiting to find
and make a bootable CD with a sufficiently up-to-date version of
ntfsresize on it (I eventually used KNOPPIX, I think).  Then I
repartitioned, carefully following the instructions about making sure
that things begin and end in the right places, figuring out what
should be primary or not, betting that my very modern BIOS could, in
fact, boot an OS past the 1024th cylinder, and so on.  In the end, all
I had to show for it was an invalid partition table.

Being a long-time Linux user and not really having wanted Windows on
the machine in the first place (and tired of being stuck in Linux
Install World of Pain), I wiped the hard drive and installed Fedora
Core 3 from scratch.  For most people, it would be really, really nice
if the Fedora installer could Do The Right Thing, and do it correctly.

Thanks for reading,

Beland
Comment 1 Jeremy Katz 2005-01-20 11:18:49 EST
Unfortunately, code for dealing with NTFS cannot be shipped due to patent reasons.

Note You need to log in before you can comment on or make changes to this bug.