Bug 1456285 - python34 doesn't include ensurepip/_bundled/{pip,setuptools}...whl, breaking venv
python34 doesn't include ensurepip/_bundled/{pip,setuptools}...whl, breaking ...
Status: CLOSED DUPLICATE of bug 1263057
Product: Fedora EPEL
Classification: Fedora
Component: python34 (Show other bugs)
epel7
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Petr Viktorin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-28 14:28 EDT by Bowe Strickland
Modified: 2017-05-28 14:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-28 14:39:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2017-05-28 14:28:57 EDT
Description of problem:

Because the python34-libs package doesn't include the _bundled pip and setuptools wheels, creation of virtual environment fails upon attempting to bootstrap pip.  Copying the bundled whls from the Fedora package solves the problem.


Version-Release number of selected component (if applicable):

[root@util-1 ~]# rpm -qf /usr/lib64/python3.4/ensurepip
python34-libs-3.4.5-3.el7.x86_64

How reproducible:
Very


Steps to Reproduce:
1. Install python34 from epel-7
2. use "python34 -m venv /opt/vevn/demo" to attempt to create a virtual env
3.

Actual results:
[root@util-1 ~]# python3.4 -m venv /opt/venv/demo
Error: Command '['/opt/venv/demo/bin/python3.4', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1


Expected results:
Successful creation of virtual env


Additional info:

Examination of the python34 package from Fedora finds the wheels needed to bootstrap the environment provided, and manually copying the wheels from a Fedora system solves the issue.

# examine on a Fedora25 system, and copy to a RHEL7
[bowe@localhost _bundled]$ cat /etc/redhat-release 
Fedora release 25 (Twenty Five)
[bowe@localhost _bundled]$ rpm -ql python34 | grep _bundled
/usr/lib64/python3.4/ensurepip/_bundled
/usr/lib64/python3.4/ensurepip/_bundled/pip-8.1.1-py2.py3-none-any.whl
/usr/lib64/python3.4/ensurepip/_bundled/setuptools-20.10.1-py2.py3-none-any.whl
[bowe@localhost ensurepip]$ rsync -aP _bundled util-1:/usr/lib64/python3.4/ensurepip

# now RHEL7 system works
[root@util-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.1 (Maipo)
[root@util-1 ~]# python3.4 -m venv /opt/venv/demo
[root@util-1 ~]#
Comment 1 Bowe Strickland 2017-05-28 14:39:42 EDT
While similar to Bug 1411685, this solution avoids python-virtualenv requirement.
This solution is similar to Bug 1263057.

*** This bug has been marked as a duplicate of bug 1263057 ***

Note You need to log in before you can comment on or make changes to this bug.