Bug 145630 - aspell --mode=sgml loops endlessly
Summary: aspell --mode=sgml loops endlessly
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: aspell (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 187539
TreeView+ depends on / blocked
 
Reported: 2005-01-20 09:16 UTC by Peter Collinson
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0310
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 21:12:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0310 normal SHIPPED_LIVE aspell bug fix update 2006-07-19 18:25:00 UTC

Description Peter Collinson 2005-01-20 09:16:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20050104 Red Hat/1.4.3-3.0.7

Description of problem:
aspell check index.html
does not to terminate. The memory footprint grows and grows. Running
strace shows that it's in some loop trying to allocate memory.

aspell --mode=none check index.html
will operate correctly.

Trying LANG=C aspell check index.html
to remove possible locale problems has the same effect.

(I don't see an easy way of reverting to a previous aspell version,
too many dependencies).


Version-Release number of selected component (if applicable):
aspell-0.33.7.1-25.3

How reproducible:
Always

Steps to Reproduce:
1. aspell check anyfile.html
2.
3.
    

Actual Results:  Nothing. It sits and waits.

Expected Results:  A spell check screen should appear.

Additional info:

Comment 1 Scott O'Neil 2005-04-18 21:29:30 UTC
I'm also able to recreate this problem using aspell-0.33.7.1-25. I use the
following command:

 /usr/bin/aspell -a -d american  -H

This is actually a pretty serious problem. If anyone uses Horde/IMP webmail on
my server, and asks Horde/IMP to do Spell Check, it uses these options and this
causes my server to crash! This seems like a simple way to crash a server remotely.

Thanks

Comment 2 Scott Russell 2005-06-28 15:56:00 UTC
Also confirmed in RHEL 3 i386 AS U5 with aspell-0.33.7.1-25.3 installed.

Comment 3 Matthias Schroder 2005-10-04 16:43:21 UTC
In the strace logfile we found the suspicious line 

open("/usr/share/aspell/SGML&iso8859-1.map", O_RDONLY) = -1 ENOENT (No such file
or directory)

I assume it meant to open /usr/share/aspell/SGML.map ?

Still strange that it does not handle this gracefully.

Matthias

Comment 4 Dmitry S. Makovey 2005-12-09 17:10:14 UTC
this is a serious bug disabling quite a bit of software (moodle is one example)
from working properly because it operates with HTML documents and "-H" (or
--mode=sgml) is essential... 
It's quite surprising that it haven't been adressed for longer time

Comment 5 Ivana Varekova 2005-12-15 15:06:19 UTC
Thank you for your comments. 
The test version (aspell-0.33.7.1-25.3.test), which should fix this bug is on
http://people.redhat.com/varekova/aspell/aspell-0.33.7.1-25.3.test.src.rpm (on
http://people.redhat.com/varekova/work.html there are i386 sources too). Could
you please test this version?
Ivana Varekova

Comment 6 Matthias Schroder 2005-12-15 15:54:19 UTC
The test aspell works for me. Funny thing is that I had tried the same fix, but
my version failed misserably.

Comment 7 Ivana Varekova 2005-12-16 09:26:09 UTC
Thank you for testing Matthias. Your suggestion in comment 3 is very close to
the patch in attached test version. 

Comment 8 Scott Russell 2005-12-16 13:41:17 UTC
Another confirmation that the test package solves the problem on RHEL3 AS U6
i386. I thought I saw this issue on RHEL4 AS U3 i386 but I couldn't replicate it
so I didn't test the new package there.

Thanks for getting this fixed!

Comment 9 Peter Collinson 2005-12-17 11:45:05 UTC
This fixes it for me too.. sorry I didn't respond more quickly.. 

Comment 10 Ivana Varekova 2006-01-02 15:36:31 UTC
Thank you for your tests.

Comment 20 Red Hat Bugzilla 2006-05-03 21:12:38 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0310.html



Note You need to log in before you can comment on or make changes to this bug.