Bug 145632 - please include vbetool for acpi suspend/resume
please include vbetool for acpi suspend/resume
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 05:39 EST by anthony baxter
Modified: 2014-03-16 22:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 11:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anthony baxter 2005-01-20 05:39:40 EST
I'm using FC on a Dell 5150 laptop, with a nvidia GeForce 5200Go
and the NVidia closed-source drivers. Power suspend _almost_ works
with this setup, except that on resume, the screen remains powered
off. However - if I use Matthew Garrett's vbetool (available from
http://www.srcf.ucam.org/~mjg59/vbetool/) then I can get things 
working again. After a resume, a 'vbetool post' reinitialises the
screen and powers it back up, and I'm a happy little bunny again.

Please consider shipping this tool, and maybe hooking it into the
ACPI power control setup. It makes things work, and I can't give 
higher praise than that!
Comment 1 Bill Nottingham 2005-01-20 11:37:55 EST
Hm, this seems like something better fixed in the drivers and
subsystems itself. Running this randomly looks like a bad idea.
Comment 2 anthony baxter 2005-01-22 01:47:43 EST
Yes, in an ideal world the drivers would do all this, and do it right.
Unfortunately, the nvidia driver is necessary, broken, and not fixable
(because of it's license). The vbetool makes the laptop far more
useful than it would otherwise be (lack of suspend is a serious
nuisance). 

Comment 3 Matthew Garrett 2005-02-13 19:30:11 EST
For a lot of hardware, there is inadequate documentation to allow for
reinitialisation from scratch. For laptops, it's also necessary to
reinitialise the backlight controller. In the general case, we have no
idea whatsoever how to do that. vbetool takes the success rate in ACPI
suspend/resume from ~20% to ~80%, which isn't too bad.
Comment 4 Bill Nottingham 2005-02-17 15:00:22 EST
What are the consequences of running vbetool on a device that hasn't
been tested to work with it before?
Comment 5 Matthew Garrett 2005-02-17 15:42:10 EST
Some machines with extremely broken BIOSes will hang. The incidence
rate seems to be very low, though - I've had two reports of this out
of several thousand tests (it's installed and run by default on the
current Ubuntu testing distribution). I wouldn't recommend it be run
by default unless ACPI S3 is being used.
Comment 6 Bill Nottingham 2005-04-14 11:45:18 EDT
Included in the pm-utils package as of today.

Note You need to log in before you can comment on or make changes to this bug.