Bug 1456326 - RBTools installation failed missing dependancy python2-tqdm
Summary: RBTools installation failed missing dependancy python2-tqdm
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: RBTools
Version: epel7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-29 04:16 UTC by Dhruv Paranjape
Modified: 2017-07-11 20:20 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-07-11 20:20:08 UTC


Attachments (Terms of Use)

Description Dhruv Paranjape 2017-05-29 04:16:33 UTC
Description of problem:
Failed to install RBTools using epel-release repository.

Version-Release number of selected component (if applicable):
RBTools 0.7.8-1

How reproducible:
with no RBTools previously installed just run yum install RBTools


Actual results:
Resolving Dependencies
--> Running transaction check
---> Package RBTools.noarch 0:0.7.8-1.el7.1 will be installed
--> Processing Dependency: python2-tqdm for package: RBTools-0.7.8-1.el7.1.noarch
--> Finished Dependency Resolution
Error: Package: RBTools-0.7.8-1.el7.1.noarch (epel)
           Requires: python2-tqdm
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Expected results:
installs successfully.

Comment 1 Robert Hancock 2017-06-01 17:15:42 UTC
Seems related to the fix for bug 1456326 which added the python2-tqdm dependency. tqdm is required for RBTools to work, but it doesn't appear to be in the EPEL repository.

Comment 2 Robert Hancock 2017-06-01 17:21:16 UTC
Sorry, I meant bug 1409935.

Comment 3 Fedora Update System 2017-06-01 23:47:59 UTC
RBTools-0.7.10-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 4 Fedora Update System 2017-06-01 23:48:11 UTC
python-tqdm-4.10.0-2.el7.2 RBTools-0.7.10-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6930e37c2a

Comment 5 Fedora Update System 2017-06-01 23:48:21 UTC
RBTools-0.7.10-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ddd554564

Comment 6 Fedora Update System 2017-06-01 23:48:30 UTC
RBTools-0.7.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a80f97043d

Comment 7 Fedora Update System 2017-06-01 23:48:40 UTC
RBTools-0.7.10-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f8847682d

Comment 8 Fedora Update System 2017-06-03 02:50:38 UTC
RBTools-0.7.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 9 Fedora Update System 2017-06-03 02:56:31 UTC
RBTools-0.7.10-1.el7, python-tqdm-4.10.0-2.el7.2 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6930e37c2a

Comment 10 Fedora Update System 2017-06-03 04:35:57 UTC
RBTools-0.7.10-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5ddd554564

Comment 11 Fedora Update System 2017-06-03 04:36:58 UTC
RBTools-0.7.10-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a80f97043d

Comment 12 Tuomo Soini 2017-06-04 07:55:40 UTC
Same issue on epel6. python-tqdm is not there.

Comment 13 Stephen Gallagher 2017-06-04 17:45:13 UTC
(In reply to Tuomo Soini from comment #12)
> Same issue on epel6. python-tqdm is not there.

OK, that's going to be more work, because python-tqdm's dependencies don't exist on RHEL 6 either. I'll try to look into it this week if I can.

Comment 14 Fedora Update System 2017-06-04 19:39:49 UTC
RBTools-0.7.10-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3f8847682d

Comment 15 Fedora Update System 2017-06-13 19:55:58 UTC
RBTools-0.7.10-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-06-14 03:17:52 UTC
RBTools-0.7.10-1.el7, python-tqdm-4.10.0-2.el7.2 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-06-14 07:21:53 UTC
RBTools-0.7.10-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2017-06-16 14:14:55 UTC
RBTools-0.7.10-1.el6 python-tqdm-4.10.0-2.el6.2 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 19 Fedora Update System 2017-06-18 02:46:08 UTC
RBTools-0.7.10-1.el6, python-tqdm-4.10.0-2.el6.2 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 20 Fedora Update System 2017-06-19 12:46:36 UTC
RBTools-0.7.10-1.el6 python-flake8-2.0-5.el6 python-tqdm-4.10.0-2.el6.2 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 21 Fedora Update System 2017-06-20 02:16:02 UTC
RBTools-0.7.10-1.el6, python-flake8-2.0-5.el6, python-tqdm-4.10.0-2.el6.2 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a281c013fd

Comment 22 Fedora Update System 2017-07-11 20:20:08 UTC
RBTools-0.7.10-1.el6, python-flake8-2.0-5.el6, python-tqdm-4.10.0-2.el6.2 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.