Bug 1456421 - Cannot build packages in epel-6 with mock-1.14 due to new chroot
Summary: Cannot build packages in epel-6 with mock-1.14 due to new chroot
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Clark Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1468802 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-29 11:26 UTC by Lukas Slebodnik
Modified: 2017-08-09 08:42 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-08-09 08:42:41 UTC


Attachments (Terms of Use)

Description Lukas Slebodnik 2017-05-29 11:26:46 UTC
Description of problem:
mock-1.4.1-1 uses new-chroot/systemd-nspawn by default. But rebuilding pacakges in epel-6-* fails with new-chroot :-) 

Version-Release number of selected component (if applicable):
mock-1.4.1-1.fc26.noarch

How reproducible:
Deterministic

Steps to Reproduce:
1. wget https://kojipkgs.fedoraproject.org//packages/mock/1.3.4/1.el6/src/mock-1.3.4-1.el6.src.rpm
2. mock --root epel-6-x86_64 --rebuild mock-1.3.4-1.el6.src.rpm --resultdir .

Actual results:
Start: build phase for mock-1.3.4-1.el6.src.rpm
Start: build setup for mock-1.3.4-1.el6.src.rpm
ERROR: Exception(mock-1.3.4-1.el6.src.rpm) Config(epel-6-x86_64) 0 minutes 12 seconds
INFO: Results and/or logs in: .
INFO: Cleaning up build root ('cleanup_on_failure=True')
Start: clean chroot
Finish: clean chroot
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M 6db931a0dcb145cf845fe9e6953cea5c -D /var/lib/mock/epel-6-x86_64/root -a --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=en_US.UTF-8 -u mockbuild /bin/rpm -Uvh --nodeps /builddir/build/originals/mock-1.3.4-1.el6.src.rpm

Expected results:
build pass without any additional parameters.

Additional info:
workaround is to explicitly use old-chroot

mock --old-chroot --root epel-6-x86_64 --rebuild mock-1.3.4-1.el6.src.rpm --resultdir .

Comment 1 Miroslav Suchý 2017-06-05 15:40:03 UTC
Fixed in commit 66594390f9c10766b517ab20a41b529a9ec7e315
The nspawn is switched off in epel-6-* configs.
See https://bugzilla.redhat.com/show_bug.cgi?id=1301953#c4 for more details.

Comment 2 Fedora Update System 2017-06-19 07:13:04 UTC
mock-1.4.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-21b345dd60

Comment 3 Fedora Update System 2017-06-19 07:14:03 UTC
mock-1.4.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3d88d9f8b5

Comment 4 Fedora Update System 2017-06-19 07:14:57 UTC
mock-1.4.2-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-65be829503

Comment 5 Fedora Update System 2017-06-19 14:53:07 UTC
mock-1.4.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-65be829503

Comment 6 Fedora Update System 2017-06-19 15:52:41 UTC
mock-1.4.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-21b345dd60

Comment 7 Fedora Update System 2017-06-19 19:24:51 UTC
mock-1.4.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3d88d9f8b5

Comment 8 Fedora Update System 2017-06-25 16:20:01 UTC
mock-1.4.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-07-04 01:51:59 UTC
mock-1.4.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-07-06 05:19:34 UTC
mock-1.4.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Miroslav Suchý 2017-07-10 12:58:19 UTC
*** Bug 1468802 has been marked as a duplicate of this bug. ***

Comment 12 Irina Boverman 2017-08-08 18:04:43 UTC
Using mock-1.4.2-1.fc25.noarch.
mock build for RHEL 6 fails:

Mock Version: 1.4.2
ENTER ['do'](['bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target x86_64 --nodeps /builddir/build/SPECS/qpid-proton.spec'], gid=135timeout=86400user='mockbuild'nspawn_args=[]printOutput=Falseshell=Falseenv={'SHELL': '/bin/bash', 'LANG': 'en_US.UTF-8', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'HOSTNAME': 'mock', 'TERM': 'vt100', 'HOME': '/builddir'}logger=<mockbuild.trace_decorator.getLog object at 0x7f4690231438>uid=0chrootPath='/var/lib/mock/amq-clients-1-rhel-6-candidate-x86_64/root')
Executing command: ['/usr/bin/systemd-nspawn', '-q', '-M', '830c4c3536ab4b58a3dcbdaaae1ea28d', '-D', '/var/lib/mock/amq-clients-1-rhel-6-candidate-x86_64/root', '-a', '--setenv=SHELL=/bin/bash', '--setenv=LANG=en_US.UTF-8', '--setenv=PS1=<mock-chroot> \\s-\\v\\$ ', '--setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin', '--setenv=PROMPT_COMMAND=printf "\\033]0;<mock-chroot>\\007"', '--setenv=HOSTNAME=mock', '--setenv=TERM=vt100', '--setenv=HOME=/builddir', '-u', 'mockbuild', 'bash', '--login', '-c', '/usr/bin/rpmbuild -bs --target x86_64 --nodeps /builddir/build/SPECS/qpid-proton.spec'] with env {'SHELL': '/bin/bash', 'LANG': 'en_US.UTF-8', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'HOSTNAME': 'mock', 'TERM': 'vt100', 'HOME': '/builddir'} and shell False
getent initgroups failed with error code 1.
Failed to parse group data from getent.
Child died too early.
Child return code was: 1
EXCEPTION: [Error()]

Comment 13 Miroslav Suchý 2017-08-09 08:42:41 UTC
Irina please make sure that you have your config updated.

I guess that you have unmerged /etc/mock/epel-6-x86_64.cfg.rpmnew on your disk.
Running:
  rpmconf -o mock
will guide you through merge.


Note You need to log in before you can comment on or make changes to this bug.