Bug 1456603 - Packages with longer names are ignored during package updates (#24330)
Summary: Packages with longer names are ignored during package updates (#24330)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ansible
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1456604 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-29 19:42 UTC by Jan Chaloupka
Modified: 2017-06-19 12:43 UTC (History)
9 users (show)

Fixed In Version: ansible-2.3.1.0-1.el6 ansible-2.3.1.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-17 21:18:11 UTC


Attachments (Terms of Use)

Description Jan Chaloupka 2017-05-29 19:42:04 UTC
When updating rpms with the package module with docker container as a driver packages with longer names are ignored and the module reports all packages are up-to-date. E.g.

```yaml
- hosts: container_host
  tasks:
  - name: "Update packages"
    package:
      name: "verylongpackagenamethatiscompletelyignoredfromtheupdates"
      state: "latest"
```

The issues is upstream reported and fixed by https://github.com/ansible/ansible/pull/24331.

Version-Release number of selected component (if applicable):
ansible-2.3.0.0-4.el7

This blocks molecule testing of ansible roles.

Comment 1 Kevin Fenzi 2017-05-29 20:25:49 UTC
*** Bug 1456604 has been marked as a duplicate of this bug. ***

Comment 2 Kevin Fenzi 2017-05-29 20:31:30 UTC
I'm hoping 2.3.1 should be out soon with this fix... 

will see next week. If not, we can push a version with the patch, but hopefully 2.3.1 will be out. :)

Comment 3 Jan Chaloupka 2017-05-29 21:30:54 UTC
Thanks for closing the dup :) I had to resubmit the form when the page got blank.

Yeah, on Fedora it is not such a blocker and can wait for a while.

Comment 4 Fedora Update System 2017-06-01 23:06:31 UTC
ansible-2.3.1.0-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5279a157d2

Comment 5 Fedora Update System 2017-06-01 23:06:59 UTC
ansible-2.3.1.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b316d2bb3b

Comment 6 Fedora Update System 2017-06-03 02:50:21 UTC
ansible-2.3.1.0-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-5279a157d2

Comment 7 Fedora Update System 2017-06-03 02:56:17 UTC
ansible-2.3.1.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b316d2bb3b

Comment 8 Pavel Cahyna 2017-06-15 16:42:40 UTC
Does 2.3.1 fix your problem?

Comment 9 Fedora Update System 2017-06-17 21:18:11 UTC
ansible-2.3.1.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-06-17 21:20:48 UTC
ansible-2.3.1.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Jan Chaloupka 2017-06-19 12:43:58 UTC
Ja. The https://github.com/ansible/ansible/pull/24331 is applied in 2.3.1.


Note You need to log in before you can comment on or make changes to this bug.