Bug 1456856 - Cloudforms includes cached memory when computing used memory of openshift 3.3 providers
Summary: Cloudforms includes cached memory when computing used memory of openshift 3.3...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: All
OS: All
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Yaacov Zamir
QA Contact: Shalom Naim
URL:
Whiteboard: container:c&u
Depends On: 1457933
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-30 14:22 UTC by Felix Dewaleyne
Modified: 2019-10-22 13:21 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-22 09:27:32 UTC
Category: ---
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)
the heapster endpopints found (cant find cache or rss) (63.03 KB, image/png)
2017-06-01 14:15 UTC, Yaacov Zamir
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3060081 None None None 2017-05-30 14:23:13 UTC

Description Felix Dewaleyne 2017-05-30 14:22:05 UTC
Description of problem:
Cloudforms includes cached memory when computing used memory of openshift 3.3 providers - this means that the used memory alerts generated are not useful
*
Version-Release number of selected component (if applicable):
cfme-5.7.0
openshift 3.3.1.11

How reproducible:
all the time

Steps to Reproduce:
1. set up openshift
2. set up cloudforms to use the openshift provider
3. make openshift consumption grow (java processes using cache memory)

Actual results:
cloudforms alerts are generated without taking into account that cached memory is reclaimable

Expected results:
Cloudforms doesn't take cached memory into account when computing the memory usage of openshift providers

Additional info:
planning to re-test against cfme-5.7.2.1

Comment 4 Yaacov Zamir 2017-06-01 14:15:01 UTC
Created attachment 1284157 [details]
the heapster endpopints found (cant find cache or rss)

Comment 6 Federico Simoncelli 2017-06-01 15:25:55 UTC
To make it explicit: ATM this CFME bug/RFE is blocked on OpenShift Heapster which is not collecting and exposing the information about used memory vs cache.

Solving this issue has to be prioritized first in bug 1457933 (OpenShift Metrics).

Comment 8 Dave Johnson 2017-07-14 03:46:58 UTC
Please assess the importance of this issue and update the priority accordingly.  Somewhere it was missed in the bug triage process.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#priority for a reminder on each priority's definition.

If it's something like a tracker bug where it doesn't matter, please set it to Low/Low.

Comment 14 Eric Rich 2017-09-07 18:20:57 UTC
This seems related to https://bugzilla.redhat.com/show_bug.cgi?id=1485504

Comment 16 Barak 2017-12-10 15:36:33 UTC
Loic,

This needs a PM's decision.
Please let me know what version you think we can do the change for.
For now pushing to 6.0 as this may require a DB schema change.

Comment 17 Barak 2017-12-26 15:17:07 UTC
Loic,

This is a wider issue than just collecting the RSS, as in cfme the used memory columns are always a sum of cached & RSS.

As Prometheus reports all the memory data required, We can collect the parameters separately , and we can store these in separate columns, however the question is what should we do with those params, other than expose them for reports. which may bring a different set of questions about what is used for charge back ??

Please advise.

Comment 22 Yaacov Zamir 2018-01-22 09:27:32 UTC
Barak:
> I suggest adding a chached column in the metric table (we could add 2
> columns RSS & cache ) or we can calculate the third (total = RSS + cache).

Loic:
> The two customers ticket are closed, I am proposing to fix it with Prometheus.

The proposed solution is to add "cached" and "rss" columns to the metrics table, and populate them only if we have a prometheus metrics.

closing as not a bug because showing "used_memory" on the "used memory" column is what is expected and documented, if we want to add new columns for providers using prometheus metrics collector we need an RFE.


Note You need to log in before you can comment on or make changes to this bug.