Bug 1456877 - [downstream clone - 4.1.3] [RFE] add swap to rhevm-appliance
Summary: [downstream clone - 4.1.3] [RFE] add swap to rhevm-appliance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance
Version: 4.0.6
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.3
: ---
Assignee: Ryan Barry
QA Contact: Gonza
URL:
Whiteboard:
Depends On: 1422982
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-30 15:14 UTC by rhev-integ
Modified: 2019-04-28 14:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, the self-hosted engine setup failed if the system clock was set to a time zone that was behind UTC during the installation. This is due to the fact that the Red Hat Virtualization Host generates VDSM certificates at the first boot and if the clock is incorrect, the chronyd or ntpd processes resynchronized the clock. This lead to an invalid certificate if the time zone was behind UTC. Now, Red Hat Virtualization Host generates the certificates after the chronyd or ntpd processes, and waits two seconds for the clock to synchronize. Note that if the Red Hat Virtualization Host is configured after the installation, or if the NTP server is too slow, the self-hosted engine setup may fail.
Clone Of: 1422982
Environment:
Last Closed: 2017-07-06 07:33:16 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1702 normal SHIPPED_LIVE rhvm-appliance bug fix and enhancement update for RHV 4.1 2017-07-06 11:25:44 UTC
oVirt gerrit 77269 master MERGED engine-appliance: enable swap 2017-05-30 15:14:51 UTC
oVirt gerrit 77370 ovirt-4.1-snapshot MERGED engine-appliance: enable swap 2017-05-30 15:14:51 UTC
oVirt gerrit 77374 ovirt-4.1-pre MERGED engine-appliance: enable swap 2017-05-30 15:14:51 UTC
oVirt gerrit 77377 ovirt-4.1 MERGED engine-appliance: enable swap 2017-05-30 15:14:51 UTC

Description rhev-integ 2017-05-30 15:14:43 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1422982 +++
======================================================================

Description of problem:
rhevm-appliance has no swap by default, this is contrary to 
https://access.redhat.com/solutions/15244
where a system with 16GiB of RAM should have at least 8GiB of swap.

Version-Release number of selected component (if applicable):
rhevm-appliance-20161214.0-1.el7ev

How reproducible:
Always

Steps to Reproduce:
1. Install RHV using the hosted engine (rhevm-appliance)
2. launch free -m on the appliance

Actual results:
No swap

Expected results:
8GiB+ swap

Additional info:
swap is required especially since additional tools must be installed on the manager (3rd party backup tools, etc) which might increase memory pressure.

(Originally by Francois-Dominique Cami)

Comment 2 Emma Heftman 2017-06-20 11:46:58 UTC
Hi Ryan. I'm looking at the doc text. Could you pls. explain what you mean by "user additions"? Thanks!

Comment 3 Ryan Barry 2017-06-20 12:34:39 UTC
I'm imagining vendor tools or something which a customer environment requires for standardization (powerbroker, etc)

Comment 4 Gonza 2017-06-21 07:39:33 UTC
Verified with:
rhvm-appliance-20170619.0-1

[root@10-34-61-172 ~]# free -h
total        used        free      shared  buff/cache   available
Swap:          8.0G          0B        8.0G

Comment 5 Emma Heftman 2017-06-21 08:01:57 UTC
(In reply to Ryan Barry from comment #3)
> I'm imagining vendor tools or something which a customer environment
> requires for standardization (powerbroker, etc)

Thanks

Comment 9 errata-xmlrpc 2017-07-06 07:33:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1702


Note You need to log in before you can comment on or make changes to this bug.