Bug 145692 - Kopete fails to store passwords in kde wallet
Kopete fails to store passwords in kde wallet
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 12:53 EST by Pavel Simerda
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 08:35:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Simerda 2005-01-20 12:53:16 EST
Description of problem: 
* When I check remember password in account properties and specify 
the password, it is not correctly stored in KWallet, only asterisks 
(*) appear istead of real character. And i am told the password is 
wrong and asked for it.  
  
 * Then I enter the password and again I choose to remember password 
but this time it doesn't do anything regardless whether there is a 
'wrong' password or no password at all in the wallet.  
  
I tried it many times experiencing the same behavior.  
 
I filed it at kde (http://bugs.kde.org/show_bug.cgi?id=97539) but the 
response was: 
 
From Matt Rogers 2005-01-20 17:35 
this is probably redhat specific. The password saving code hasn't 
changed since 0.9.0 and it works for me on KDE 3.4 beta 1. You can 
try filing a bug with redhat at bugzilla.redhat.com and see what 
happens, but we can't do anything about it if we can't reproduce it.  
  
Version-Release number of selected component (if applicable): 
kdenetwork-3.3.1 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Start kopete and configure an ICQ account to remember password 
2. Check kde wallet 
3. Remove the 'wrong' password 
4. Choose ICQ Account -> Go online 
5. Chech kde wallet again 
   
Actual results: 
Password is either stored as a string of asterisks or not at all 
 
 
Expected results: 
Password should be stored in the wallet in either case and used the 
next time logging in
Comment 1 Pavel Simerda 2005-01-20 12:58:55 EST
When I add the password manually to the wallet, all workes so the 
only problem is that kopete doesn't store it. 
 
Comment 2 Pavel Simerda 2005-01-27 15:15:29 EST
Now after some updates it seems Kopete stores at least the second 
case.... but when using account settings it still stores only the 
asterisks. 
 
But kwallet somehow looses the passwords (maybe after restart?). I 
will write more later but I'd like to see some reaction to know I am 
not wasting my time with these bugreports. 
Comment 3 Petr Rockai 2005-03-11 09:12:29 EST
Will look into this over the next week or so. Please provide as much info as 
you can in the meantime, thanks. 
Comment 4 Pavel Simerda 2005-03-13 06:33:31 EST
Storing password /while connecting/ works well but still when I choose to 
remember password in Kopete settings, it stores a set of asterisks instead of 
the real password. Using Fedora Core, Kopete 0.9.1, KDE 3.3.1. 
Comment 5 Petr Rockai 2005-03-14 04:00:51 EST
Ok, i can reproduce the bug here. I will investigate ASAP. 
Comment 6 Petr Rockai 2005-03-14 14:43:59 EST
Status update: compiling possibly fixed version. It is also fixed in  
development/rawhide, via upload of kde 3.4. I'll try to get the fix into FC3  
updates... Will report back then. 
Comment 7 Ngo Than 2005-03-15 08:35:30 EST
the kdenetwork-3.3.1-3 has now this fix. I will put it into FC-3 updates
today. Thanks Peter

Note You need to log in before you can comment on or make changes to this bug.