Bug 145699 - gFTP should not disconnect on 4xx return code from server
gFTP should not disconnect on 4xx return code from server
Status: CLOSED DUPLICATE of bug 145711
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jonathan Blandford
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 13:19 EST by Don Russell
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Russell 2005-01-20 13:19:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Not every ftp server has a default working directory upon logon.

When gFTP connects and logs on it issues a PWD command.
When there is no default working directory, gFTP sees return code 450
and promptly disconnects, saying it will try again 30 seconds.

This is wrong. gFTP should remain connected, and allow the user to use
the drop down menus to manually change directory.

Version-Release number of selected component (if applicable):
2.0.17

How reproducible:
Always

Steps to Reproduce:
1. ftp to: sruvm.sru.edu
2. anonymous
3.
    

Actual Results:  Looking up sruvm.sru.edu
Trying sruvm.sru.edu:21
Connected to sruvm.sru.edu:21
220-FTPSERVE IBM VM V2R4 at SRUVM.SRU.EDU, 12:59:21 EST THURSDAY 01/20/05
220 Connection will close if idle for more than 5 minutes.
USER anonymous

230-ANONYMOU logged in; no working directory defined
230 File pool SERVER5 unavailable or unknown;
SYST

215-VM/ESA Version 2 Release 3.0, service level 9902
    VM/CMS Level 14, Service Level 902
215 VM is the operating system of this server.
TYPE I

200 Representation type is IMAGE.
PWD

450 No current working directory defined
Invalid response '4' received from server.
Disconnecting from site sruvm.sru.edu
Waiting 30 seconds until trying to connect again

Expected Results:  gFTP should have left well enough alone and stayed
connected after getting the 450 from the PWD command.

Additional info:

I'm setting this as "high severity", not because it crashes etc, but
because it diminshes the usefulness of the program... there's no way
to effectively use the ftp server if the server doesn't have a default
working directory.

4xx erros from FTP means the condition is temporary and may be tried
again..... so gFTP must not disconnect from the server in those cases.
Comment 1 Don Russell 2005-01-20 19:00:46 EST

*** This bug has been marked as a duplicate of 145711 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.