Bug 14570 - annoying beep when starting vim in an xterm
Summary: annoying beep when starting vim in an xterm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-24 23:53 UTC by John Cagle
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-06 12:03:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Cagle 2000-07-24 23:53:31 UTC
vim (v5.7) 'beeps' every time you start it up in a gnome-terminal, xterm,
kterm or rxvt.  If I set TERM to "xf" (equivalent to xterm), the beep goes away.

Problem seems to be related to parsing of /etc/termcap.  For instance,
if you edit /etc/termcap and change the 'xterm' entry to 'xxterm',
then set TERM=xxterm in your shell, vim no longer beeps when starting.

Maybe vim can't handle too many termcap entries starting with 'xterm'?

Comment 1 Bernhard Rosenkraenzer 2000-07-25 14:00:22 UTC
I can't reproduce it in an xterm and an rxvt, but it does seem to happen in
gnome-terminal.
Are you sure this happens for you in xterm and rxvt?

Comment 2 John Cagle 2000-07-25 21:40:39 UTC
Yes.  It happens in xterm and rxvt, but only if the TERM
environment variable is set to "xterm", as it is by default.
It happens on *ALL* the machines I've installed beta 4 on.

Comment 3 John Cagle 2000-07-28 16:28:46 UTC
Still occurs with pinstripe.

Comment 4 Tim Waugh 2000-08-05 17:46:38 UTC
This has been happening since about Red Hat Linux 6.2.  I think it's a vim bug:
look for KS_CRV: \e[>c is the string that's making the beep.  vim-5.3 doesn't
have this behaviour, but at least 5.6-11 does.  Checking 5.5..

Comment 5 Tim Waugh 2000-08-06 12:03:39 UTC
This happens for vim-minimal only, I think.

Bero, please take a look at ~twaugh/fixes/vim-5.7-6.src.rpm, which fixes the
problem for me. (I've only tested vim-minimal.)

Comment 6 Bernhard Rosenkraenzer 2000-08-07 14:14:04 UTC
The patch seems to work well - I'm currently building it in the 7.0 tree.


Note You need to log in before you can comment on or make changes to this bug.