Bug 145706 - orinoco WLAN broken in 2.6.10-1.741_FC3
orinoco WLAN broken in 2.6.10-1.741_FC3
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2005-01-20 14:20 EST by Ulrich Kiermayr
Modified: 2015-01-04 17:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-01 23:32:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ulrich Kiermayr 2005-01-20 14:20:55 EST
Description of problem:
The orinoco WLAN is broken for me (Dell Latitude C400 internal WLAN)
with the kernel-2.6.10-1.741_FC3. It works fine with

Version-Release number of selected component (if applicable):

How reproducible:
Fails to initialize the Driver during boot.

Actual results:
Trying to load the driver (during boot) results in 
Jan 20 12:22:02 worf kernel: orinoco_cs: Unknown symbol
Jan 20 12:22:02 worf kernel: orinoco_cs: Unknown symbol orinoco_interrupt
Jan 20 12:22:02 worf kernel: orinoco_cs: Unknown symbol __orinoco_up
Jan 20 12:22:02 worf kernel: orinoco_cs: Unknown symbol __orinoco_down
Jan 20 12:22:02 worf kernel: orinoco_cs: Unknown symbol alloc_orinocodev

and no WLAN avaliable
Comment 1 Aaron Gaudio 2005-01-22 00:48:43 EST
When I try to load the orinoco_cs module in this version of the
kernel, I get a different list of errors:

 orinoco_cs: Unknown symbol cs_error
orinoco_cs: Unknown symbol pcmcia_get_first_tuple
orinoco_cs: Unknown symbol pcmcia_unregister_driver
orinoco_cs: Unknown symbol pcmcia_get_tuple_data
orinoco_cs: Unknown symbol pcmcia_get_next_tuple
orinoco_cs: Unknown symbol pcmcia_validate_cis
orinoco_cs: Unknown symbol pcmcia_get_configuration_info
orinoco_cs: Unknown symbol pcmcia_parse_tuple
orinoco_cs: Unknown symbol pcmcia_reset_card
orinoco_cs: Unknown symbol pcmcia_register_driver

In the case of the pcmcia_* symbols, it appears that those function
names changed in the pcmcia_core module to use "pccard" instead of
Comment 2 Dave Jones 2005-01-22 00:56:54 EST
is this still a problem with teh kernel in
http://people.redhat.com/davej/kernels/Fedora/FC3/  ?

The driver loads, and works just fine for me, so I'm puzzled.

Are you trying to load it manually with insmod ? (if so, use modprobe
Comment 3 Ulrich Kiermayr 2005-01-22 04:39:36 EST
2.6.10-1.750_FC3 works again.

and I tried modprobe with no sucess (and i think the init-scripts do a
modprobe as well?).

lG uk
Comment 4 Aaron Gaudio 2005-02-03 23:45:28 EST
I tried kernel-2.6.10-1.760_FC3 and I'm still having the same problem with the
pcmcia_* symbols. Shall we re-open this or shall I create a new bug entry?
Comment 5 Aaron Gaudio 2005-02-03 23:58:46 EST
I take it back. I had a mischevious entry for "pcmcia" in /etc/modprobe.conf
that caused the new pcmcia.ko module to not get loaded. Disregard.

Note You need to log in before you can comment on or make changes to this bug.