Bug 1457087 - Insufficient logging for failed VM live migration with missing direct pass-though LUN
Summary: Insufficient logging for failed VM live migration with missing direct pass-th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.2.1
: ---
Assignee: Eyal Shenitzky
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks: 1516909
TreeView+ depends on / blocked
 
Reported: 2017-05-31 05:56 UTC by Roman Hodain
Modified: 2020-06-11 13:53 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.2.1.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:42:49 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:44:33 UTC
oVirt gerrit 84512 0 'None' 'ABANDONED' 'core: Add LUNs connectivity validation prior to VM migration' 2019-12-09 05:33:41 UTC
oVirt gerrit 84679 0 'None' 'MERGED' 'core: Improve logging for failed VM live migration' 2019-12-09 05:33:41 UTC

Description Roman Hodain 2017-05-31 05:56:38 UTC
Description of problem:
Insufficient information is displayed for failed live migration of VM with direct pass-through lun when the direct LUN is not available on the destination host.

Version-Release number of selected component (if applicable):
RHV 4.0

How reproducible:
100%

Steps to Reproduce:
1. Create VM with direct LUN pass-through 
2. Zone this LUN to source hypervisor and start the VM
3. live migrate the VM to a host where the LUN is not available

Actual results:
 2017-05-14 12:00:01,003 | Migration failed  (VM: VM01, Source: host01.example.com).
 2017-05-14 12:00:01,002 | No available host was found to migrate VM VM01 to.
 2017-05-14 12:00:01,001 | Failed to migrate VM VM01 to Host host02.example.com . Trying to migrate to another Host.

Expected results:

 Error message should let the user know whay exactly the migration failed. In this case the following information whoudl be displayed:

    1) The Direct pass through LUN xxxx-xxxx-xxxx-xxxx is not available on the host host02.example.com

The user has to be able to identify the issue without investigating the logs.

Additional info:

Destination vdsm:

Thread-1534::INFO::2017-05-14 11:53:45,842::logUtils::52::dispatcher::(wrapper) Run and protect: getDevicesVisibility, Return response: {'visible': {u'2dbb99ec54087f1816c9ce900af073231': False}}
Thread-1534::DEBUG::2017-05-14 11:53:45,842::task::1193::Storage.TaskManager.Task::(prepare) Task=`e5d8fe46-a8a8-454d-9d5f-75e0e3f58b35`::finished: {'visible': {u'2dbb99ec54087f1816c9ce900af073231': False}}

...

Thread-1534::DEBUG::2017-05-14 11:53:45,843::task::995::Storage.TaskManager.Task::(_decref) Task=`e5d8fe46-a8a8-454d-9d5f-75e0e3f58b35`::ref 0 aborting False
Thread-1534::ERROR::2017-05-14 11:53:45,843::vm::773::virt.vm::(_startUnderlyingVm) vmId=`38639856-6f6a-48ef-b848-d7a1264aa994`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/vm.py", line 714, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/virt/vm.py", line 1940, in _run
    self._preparePathsForDrives(dev_spec_map[hwclass.DISK])
  File "/usr/share/vdsm/virt/vm.py", line 799, in _preparePathsForDrives
    drive['path'] = self.cif.prepareVolumePath(drive, self.id)
  File "/usr/share/vdsm/clientIF.py", line 331, in prepareVolumePath
    raise vm.VolumeError(drive)
VolumeError: Bad volume specification {u'index': 0, u'iface': u'scsi', u'apparentsize': u'107374182400', u'name': u'sda', u'format': u'raw', u'bootOrder': u'1', u'sgio': u'filtered', u'GUID': u'2dbb99ec54087f1816c9ce900af073231', u'specParams': {}, u'readonly': u'False', u'alias': u'scsi0-0-0-0', u'optional': u'false', u'deviceId': u'97dc97a4-8b6a-4b32-9b71-13242c0b75ff', u'truesize': u'107374182400', u'address': {u'bus': u'0', u'controller': u'0', u'type': u'drive', u'target': u'0', u'unit': u'0'}, u'device': u'lun', u'shared': u'false', u'path': u'/dev/mapper/2dbb99ec54087f1816c9ce900af073231', u'propagateErrors': u'off', u'type': u'disk'}

Comment 1 Allon Mureinik 2017-11-15 15:11:22 UTC
Actually, I'd expect the migration to fail on the engine side, and be blocked.

Comment 2 Eyal Shenitzky 2017-11-23 14:39:44 UTC
(In reply to Allon Mureinik from comment #1)
> Actually, I'd expect the migration to fail on the engine side, and be
> blocked.

Open different bug for the engine to block the migration in case of a LUN which is not visible to a host due to various of opinions on how it should be implemented as you can see in - https://gerrit.ovirt.org/#/c/84512/

Link - https://bugzilla.redhat.com/show_bug.cgi?id=1516909

Currently, implement only an improvement for the log message as suggested by Roman.

Comment 3 Allon Mureinik 2017-11-23 15:13:25 UTC
(In reply to Eyal Shenitzky from comment #2)
> (In reply to Allon Mureinik from comment #1)
> > Actually, I'd expect the migration to fail on the engine side, and be
> > blocked.
> 
> Open different bug for the engine to block the migration in case of a LUN
> which is not visible to a host due to various of opinions on how it should
> be implemented as you can see in - https://gerrit.ovirt.org/#/c/84512/
> 
> Link - https://bugzilla.redhat.com/show_bug.cgi?id=1516909
> 
> Currently, implement only an improvement for the log message as suggested by
> Roman.

Agreed. 
Returning this BZ to assigned as the patch does not apply to this request, but to the newly opened BZ 1516909

Comment 4 Kevin Alon Goldblatt 2018-01-31 15:46:43 UTC
Verified with the following cod1. Create VM with direct LUN pass-through 
2. Zone this LUN to source hypervisor and start the VM
3. live migrate the VM to a host where the LUN is not available
e:
------------------------------------------
ovirt-engine-4.2.1.3-0.1.el7.noarch
vdsm-4.20.17-11.gite2d6775.el7.centos.x86_64


Verified with the following scenario:
------------------------------------------
1. Create VM with direct LUN pass-through 
2. Zone this LUN to source hypervisor and start the VM
3. live migrate the VM to a host where the LUN is not available


Correct message displayed.


Moving to VERIFIED!

Comment 7 errata-xmlrpc 2018-05-15 17:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 8 Franta Kust 2019-05-16 13:09:36 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.