Bug 145716 - init 3 freezes at anacron program
init 3 freezes at anacron program
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 15:18 EST by ed
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 17:04:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ed 2005-01-20 15:18:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
i'm not really a computer guy but here is what happened.

I am working for the faa and we are looking for a cheaper way to do
things as is everyone else.  Fedora Core was the answer than to big
bulky and expensive displays.  We worked with fedora core 2 (don't
know the version) for a while and things looked good.  We looked to
upgrade to fedora 3 test 3 but things haven't worked out too well.  

Right after formatting the drive that previously had fedora 2 on it we
tried an init 3 which failed.  I should say it got hung up right after
anacron started.  I don't know if it was anacron that stalled the
process or if it was the program that followed.  We did not do an
upgrade - we did a complete format of the drive - fyi.

We then put on fedora 2 on the same pc and did an init 3 right after
the format.  The init 3 worked fine and did what it was supposed to do.

In both cases we didn't do ANYTHING after the format but type in init
3 after we opened up a terminal window.

Our pc's have plenty of space and juice so that shouldn't be an issue.

Don't know what other info is needed.
Thanks for any help.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. format your drive with fedora 3 or fedora 3 test 3 (both
failed)(fedora 2 works fine)
2. open terminal window and at prompt -  root@localhost ~]# type in:
"init 3"
3. 
    

Actual Results:  reboot into init 3 gets stuck at anacron

Expected Results:  boot into inti 3.

Additional info:
Comment 1 Jason Vas Dias 2005-01-20 16:08:18 EST
It just happens that anacron is the last thing to do in runlevel 3.

You may be left in a terminal that does not display a login: prompt,
but is still active & running - did you press <RETURN> ?  

Doing so should make the login: prompt appear - does it ?

Also pressing <ALT>+<F[1-6]> should switch to a virtual console (VC) 
that should display a login prompt - does it ?

After X comes up in runlevel 5, you should be able to switch to a
different VC by pressing <CTRL>+<ALT>+<F[1-6]> .

At least, that's what happens on my FC3 machine.

Comment 2 Jason Vas Dias 2005-01-20 16:18:51 EST
Actually, what appears to happen is this: in FC3 X is started up on 
virtual console 8, which never has getty / login process initiated
for it, so when you type ' init 3', you are still left on that console.

You need to press and hold the <ALT> key while pressing any of the
function keys <F1> to <F7> to switch to console on which getty is 
run and the login: prompt is displayed.



Comment 3 Jason Vas Dias 2005-01-24 17:04:02 EST
 I really cannot reproduce this.

 Yes, when you do an 'init 3' after the system has entered init state
 5 and started X, you are left in a virtual console (VC) which has no
 login: prompt, and you might think the system is hung.

 But pressing the <ALT> + any of the function keys <F1> to <F6> then
 gets you to a VC which does display the login: prompt. 

 Hence, this bug is being closed as "NOT A BUG" .

Note You need to log in before you can comment on or make changes to this bug.