Bug 145717 - printer stops working, can't find devices
printer stops working, can't find devices
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-01-20 15:26 EST by Paul Johnson
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-18 13:39:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Paul Johnson 2005-01-20 15:26:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
HP1300 on usb worked fine for a long time. Then RPM updates to FC3
cause it to stop working a lot.  Sometimes the /dev/usb/lp0 link
disappears altogether and it can't find any hardware. I think one time
I saw it looking for /dev/hal/usb0 or some such nonsense. 

Today it won't work again and when I run the FC3 printer config it
tells me to write to you.

$ system-config-printer
No match for USB device:
  mfr "Hewlett-Packard"
  model "hp LaserJet 1300"
  desc "Hewlett-Packard LaserJet 1300"
Please report this message in Bugzilla:
Choose 'foomatic' as the component.

The only complicating factor that I know of is that I recently
obtained the actual ppd file for the  hp1300 (instead of the generic
one) and put that into /usr/share/cups/model.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure printers with system-config-printer
2. Sometimes things will print, sometimes not!
3.  Running system-config-printer again and editing the printer
sometimes shows the empty box where the usb devices used to be listed.

Actual Results:  Printer frustration.

Additional info:
Comment 1 Tim Waugh 2005-01-21 05:45:37 EST
The "no match for USB device" message is harmless and can be ignored.  It just
means that the model is not automatically selected from the list (and this is
now corrected in the development package).

What kernel are you running?
Comment 2 Paul Johnson 2005-01-21 10:54:56 EST
My kernel is the newest one from FC upgrades, 2.6.10-1.741.

Your comment means there is some other reason that the usb device keeps
disappearing from the printer's configuration?
Comment 3 Tim Waugh 2005-01-21 10:57:06 EST
Yes, I think this must be a kernel issue of some sort.
Comment 4 Dave Jones 2005-07-15 14:18:08 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Paul Johnson 2005-07-18 13:39:10 EDT
I have found that a total system re-start fixes this problem after the newest
FC4 kernel upgrades.

Note You need to log in before you can comment on or make changes to this bug.