Bug 1457206 - [abrt] [faf] Invalid unref at atk_gobject_accessible_object_gone_cb()
Summary: [abrt] [faf] Invalid unref at atk_gobject_accessible_object_gone_cb()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: atk
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL: http://faf.lab.eng.brq.redhat.com/faf...
Whiteboard:
Depends On:
Blocks: 1753122 1753123
TreeView+ depends on / blocked
 
Reported: 2017-05-31 10:28 UTC by Michal Odehnal
Modified: 2019-09-18 07:35 UTC (History)
5 users (show)

Fixed In Version: atk-2.22.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:30:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 783245 Normal RESOLVED Invalid unref at atk_gobject_accessible_object_gone_cb() 2020-06-23 11:41:19 UTC
Red Hat Product Errata RHBA-2017:2100 normal SHIPPED_LIVE GTK+ bug fix update 2017-08-01 16:06:50 UTC

Description Michal Odehnal 2017-05-31 10:28:10 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/ef2faa60dce69c96c03d94935983dd023ffeb008/

Comment 2 Milan Crha 2017-05-31 10:34:32 UTC
The problem is an invalid unref in atk, causing crash in at-spi2-atk with invalid g_object_unref() call, on an already freed object. I filled an upstream bug [1] with a fix for it already.

The backtrace from the FAF report is:

Thread 1 (Thread 0x7fb800d11a80 (LWP 25909)):
#0  0x00007fb7f5c864ad in g_type_check_instance_is_fundamentally_a () from /lib64/libgobject-2.0.so.0
#1  0x00007fb7f5c68537 in g_object_unref () from /lib64/libgobject-2.0.so.0
#2  0x00007fb7eaa68b5d in expiry_func () from /lib64/libatk-bridge-2.0.so.0
#3  0x00007fb7f598ceed in g_timeout_dispatch () from /lib64/libglib-2.0.so.0
#4  0x00007fb7f598c4c9 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#5  0x00007fb7f598c818 in g_main_context_iterate.isra.21 () from /lib64/libglib-2.0.so.0
#6  0x00007fb7f598caea in g_main_loop_run () from /lib64/libglib-2.0.so.0
#7  0x00007fb7f74f94b5 in gtk_main () from /lib64/libgtk-3.so.0
#8  0x0000000000403de1 in main ()


https://bugzilla.gnome.org/show_bug.cgi?id=783245

Comment 5 Michal Odehnal 2017-06-01 07:51:21 UTC
No longer reproducable

Comment 6 errata-xmlrpc 2017-08-01 12:30:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2100

Comment 7 Milan Crha 2019-09-17 16:11:55 UTC
FOr the record, as found in bug #1717000, the change causes leaks of AtkAObject-s in other than Evolution (like in gnome-shell, which the new bug is filled for).


Note You need to log in before you can comment on or make changes to this bug.