Bug 145728 - /usr/lib/libdb.so.3 missing from compat-db-4.0.14-5.1
/usr/lib/libdb.so.3 missing from compat-db-4.0.14-5.1
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: compat-db (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 150241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 17:22 EST by Bob Plankers
Modified: 2013-07-02 19:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2006-0215
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 12:02:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Plankers 2005-01-20 17:22:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
It appears /usr/lib/libdb.so.3 is missing from the
compat-db-4.0.14-5.1 package. An "rpm --verify --all" reports:

missing    /usr/lib/libdb.so.3

I downloaded the RPM from RHN and did an "rpm -ihv --force
compat-db-4.0.14-5.1.i386.rpm". I then redid the "rpm --verify --all"
and I continued to get:

missing    /usr/lib/libdb.so.3

The 'locate' command on my machine shows the file present as
/lib/libdb.so.3. The "rpm -qf /usr/lib/libdb.so.3" command returns
compat-db as the package that owns that file. The same command on
/lib/libdb.so.3 returns "file /lib/libdb.so.3 is not owned by any package"

Version-Release number of selected component (if applicable):
compat-db-4.0.14-5.1

How reproducible:
Always

Steps to Reproduce:
1. rpm -ihv --force compat-db-4.0.14-5.1.i386.rpm
2. rpm --verify --all
3.
    

Actual Results:  missing    /usr/lib/libdb.so.3

Expected Results:  The file shouldn't be missing. :-)

Additional info:
Comment 1 Florian La Roche 2005-01-25 03:55:01 EST
Is this with RHEL3Update4? What version of rpm is installed?

Thanks,

Florian La Roche
Comment 2 Bob Plankers 2005-01-25 10:33:21 EST
compat-db-4.0.14-5.1.i386.rpm -- the one that came with RHEL3Update4.
Comment 3 James Olin Oden 2005-02-10 11:54:11 EST
jbj, this is real bug.  If you take out the %clean scriptlet and then go 
examine the /usr/lib in the build root, you will see that symlinks in question 
are there but they point to files that should be in /usr/lib.  Instead the 
files they point are in /lib.  So what you get are dangling symlinks that get 
delivered by the FSM, but as soon as the post script runs ldconfig, ldconfig 
sees the dangling symlinks and poof it removes (in RH 9 it would actually 
complain, but doesn't appear to do so in RHEL 3).  Anyway the fix is to get the 
makefiles to create the symlinks appropriately or have it create the libraries:

   libdb2.so.3  libdb-3.1.so  libdb-3.2.so  libdb-3.3.so  libdb-4.0.so

in /usr/lib rather than /lib.  Any hints on how to go about doing this would be 
appreciated, because missing files like this cause serious breakage on a 
rollback (the get packaged up, but then you get a cpio error upon delivery).

Cheers...james
Comment 4 Paul Nasrat 2005-10-12 10:27:43 EDT
*** Bug 150241 has been marked as a duplicate of this bug. ***
Comment 12 Tomas Mraz 2006-02-14 09:47:05 EST
The fix is not completely correct as ldconfig will create libdb.so.3 symlink in
/lib(64) so it should be in the same place in the package and not in
/usr/lib(64)/. Back to assigned.
Comment 22 Red Hat Bugzilla 2006-03-22 12:02:18 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0215.html

Note You need to log in before you can comment on or make changes to this bug.