Bug 145732 - clearpart does not clear linux partitions during kickstart install
clearpart does not clear linux partitions during kickstart install
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 17:42 EST by Orion Poplawski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-13 14:52:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump file from anaconda for kickstart bug (629.16 KB, text/plain)
2005-06-13 08:33 EDT, Neil Marjoram
no flags Details

  None (edit)
Description Orion Poplawski 2005-01-20 17:42:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041217

Description of problem:
Trying to re-install fedora on a previously installed system.  Install fails to allocate requested partitions because it doesn't clear out the old as requested.

kickstart config:

install
text
nfs --server=alexandria --dir=/export/data1/fedora/3/i386/cora
lang en_US
langsupport en_US C --default en_US
keyboard us
mouse
xconfig --startxonboot  --defaultdesktop KDE
network --bootproto dhcp
rootpw --iscrypted CwU/lYtazWt7E
firewall --disabled
authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com
timezone America/Denver
bootloader --location=mbr
clearpart --drives=hda --linux
part /boot --fstype ext3 --size=50
part swap --recommended
part pv.1 --size 4800 --grow
volgroup rootvg pv.1
logvol / --vgname=rootvg --size=512 --name=root
logvol /usr --vgname=rootvg --size=4000 --name=usr
logvol /var --vgname=rootvg --size=256 --name=var
logvol /export/data1 --vgname=rootvg --size=1 --name=data1 --grow

Many of our systems are dual boot and so have a windows partition first.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.  Try to install onto already installed system.
2.
3.
  

Additional info:
Comment 1 Orion Poplawski 2005-01-20 18:00:26 EST
Okay, I take it back for now.  anaconda seems to compute size needed earlier
than before and fails earlier and does not delete partitions.  This was
confusing me in this case.

I believe I've run into this elsewhere though.  I'll report more if I can reproduce.
Comment 2 Rene Klootwijk 2005-05-25 10:54:03 EDT
I experience problems which I think are related to this one. When I reinstall a
system using kickstart, every now and then kickstart fails and reports an error
like:

rpmdb: write: 0x306fdf0, 4096: No space left on device

This error occurs just after formatting the filesystems (according to the
messages on screen).
When this error occurs and I restart the kickstart installation by rebooting the
system, most of the time the installation completes succesfully.

Some details:
I am using RHEL AS3.0 U4
Have 2 72Gb SCSI disks and 8Gb internal memory
Use PXE boot
My ks.cfg file:
#Install Red Hat Linux instead of upgrade
install

# Use NFS to install
nfs --server 10.124.24.95 --dir /kickstart/x86_64

# System language
lang en_US

# Additional languages to install
langsupport en_US

# System keyboard
keyboard us

# System mouse
mouse none

# System timezone (system clock in UTC)
timezone --utc Europe/Amsterdam

# Root password
rootpw --iscrypted XaP.5c9vXo/sI

# Reboot after installation
reboot

# Use text mode install
text

# System bootloader configuration
bootloader --location=mbr

# System authorization information
auth --useshadow --enablemd5

# Firewall configuration
firewall --disabled

#Do not configure XWindows
skipx

# Partitioning
zerombr
bootloader --linear --location=mbr
#clearpart --all --drives sda,sdb --initlabel
clearpart --all
# /boot
# - RAID:        RAID 1
# - Size:        100Mb
# - Filesystem:  ext3
# - Mount point: /boot
part raid.10 --size=100 --ondisk=sda --asprimary
part raid.11 --size=100 --ondisk=sdb --asprimary
raid /boot --fstype ext3 --device=md0 --level=RAID1 raid.10 raid.11

# swap
# - RAID:        RAID 1 (to prevent a crashing system when a swap device
#                        crashes)
# - Size:        2Gb (2Gb is the maximum size for a swap device within Linux)
# - Filesystem:  swap
# - Mount point: n.a.
part raid.20 --size=2000 --ondisk=sda --asprimary
part raid.21 --size=2000 --ondisk=sdb --asprimary
raid swap  --fstype swap --device=md1 --level=RAID1 raid.20 raid.21

# vgroot (Volume group for OS)
# - RAID:        RAID 1
# - Size:        4Gb
# - Logical volumes:
#     Logical volume: lvroot
#     Size:           2Gb
#     Filesystem:     ext3
#     Mount point:    /
#
#     Logical volume: lvhome
#     Size:           512Mb
#     Filesystem:     ext3
#     Mount point:    /home
#
#     Logical volume: lvtmp
#     Size:           512Mb
#     Filesystem:     ext3
#     Mount point:    /tmp
#
#     Logical volume: lvvar
#     Size:           1Gb
#     Filesystem:     ext3
#     Mount point:    /var
part raid.30 --size=4096 --ondisk=sda --asprimary
part raid.31 --size=4096 --ondisk=sdb --asprimary
raid pv.01 --level=RAID1 --device=md2 raid.30 raid.31
volgroup vgroot pv.01
logvol /       --fstype ext3 --vgname=vgroot --size=2048     --name=lvroot
logvol /home   --fstype ext3 --vgname=vgroot --size=512      --name=lvhome
logvol /tmp    --fstype ext3 --vgname=vgroot --size=512      --name=lvtmp
logvol /var    --fstype ext3 --vgname=vgroot --size=1 --grow --name=lvvar

# vgora (Volume group for Oracle software)
# - RAID:        RAID 1
# - Size:        20Gb
# - Logical volumes:
#     Logical volume: lvoraprod
#     Size:           10Gb
#     Filesystem:     ext3
#     Mount point:    /ora/product
#
#     Logical volume: lvoraadm
#     Size:           2Gb
#     Filesystem:     ext3
#     Mount point:    /ora/admin
part raid.40 --size=20480 --ondisk=sda --asprimary
part raid.41 --size=20480 --ondisk=sdb --asprimary
raid pv.02 --level=RAID1 --device=md3 raid.40 raid.41
volgroup vgora pv.02
logvol /ora/product --fstype ext3 --vgname=vgora --size=10240 --name=lvoraprod
logvol /ora/admin   --fstype ext3 --vgname=vgora --size=2048  --name=lvoraadm

#Package install information
# Core and Base groups are automatically selected
%packages --resolvedeps
@Base
@Core
Comment 3 Neil Marjoram 2005-06-13 08:29:59 EDT
I have just attempted to reload a RHEL 4 system via kickstart, and it seems that
it is unable to clear the partitions from the hard drives prior to a reinstall.

I have tried 
clearpart --all
clearpart --drives sda,sdb
clearpart --drives sda,sdb --initlabel

But all have the same error. I have hopefully attached the dump from anaconda to
this bug.

Neil.
Comment 4 Neil Marjoram 2005-06-13 08:33:45 EDT
Created attachment 115350 [details]
Dump file from anaconda for kickstart bug

This is the dump file produced by anaconda during the install.
Comment 5 John Thacker 2007-01-13 14:52:47 EST
(This is a mass update to bugs which have been in NEEDINFO unmodified for over a
year and are for a currently unsupported version of Fedora Core.)

Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.