Bug 145733 - No way to point installer to alternate location for package dependencies
No way to point installer to alternate location for package dependencies
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 17:46 EST by John J. Germs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:57:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John J. Germs 2005-01-20 17:46:24 EST
Description of problem: When presented with the message:
"Fedora Core 3" disk needed to install packages
Insert the disk and press OK.

There is no way to point it to an alternate location.
(i.e. files on the hard drive, mounted iso image, http, ftp, etc.)

Since Fedora provides the boot.iso to perform alternate methods of
installation the system-install-packages should provide the
corresponding alternate methods of package retrieval.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora using one of the alternate methods (i.e. http install)
2. Install an rpm that requires extra software packages

3. Attempt to point the installer to the http install point
  
Actual results:
  End up hitting cancel and then not know which package was needed.
Receive errors when attempting to run the program then try to
determine wwhat package is missing. Most times the best way afterwards
is uninstall the package then try reinstalling via the command prompt.

  Ultimately the installer should not have allowed an incomplete
installation. Cancel should be Abort which would uninstall the package
that could not obtain the dependencies because no Fedora disc was found.


Expected results:

The interface should present alternate methods of retrieving the
neccessary packages.

Additional info:

Since Fedora provides a boot.iso to perform alternate methods of
installation the system-install-packages should provide the
corresponding alternate methods of package retrieval.
Comment 1 Mike MacCana 2005-04-06 22:24:44 EDT
s-c-p supports using a directory to get packages from.

Copy all the files (including the hidden ones) from the CD to /path/to/files

system-install-packages --tree=/path/to/files

However, this...
- needs to be documented in a man page, rather than --help
- needs to be configurable from within the program (GUI apps tend not to
launched from the CLI)
c) does not include other sources up2date can use, like dir and yum repositories.

So leaving open.
Comment 2 Jeremy Katz 2005-09-21 15:57:09 EDT
The options are intentionally not very documented for s-c-p due to lack of
testing.  The next generation tool which will be landing in Fedora Core 5 will
be far more flexible for things like this

Note You need to log in before you can comment on or make changes to this bug.