Bug 1457348 - Use 'https' for the redhat.com/forgot_password label
Summary: Use 'https' for the redhat.com/forgot_password label
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-31 14:33 UTC by Debarshi Ray
Modified: 2018-04-10 09:49 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.20.2-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:49:05 UTC


Attachments (Terms of Use)
RHEL74-reproducer (159.61 KB, image/png)
2017-11-10 07:52 UTC, Rehana
no flags Details
RHEL75-fixed (185.05 KB, image/png)
2017-11-10 07:54 UTC, Rehana
no flags Details
register_screen (279.63 KB, image/png)
2017-11-10 07:55 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:49:28 UTC

Description Debarshi Ray 2017-05-31 14:33:50 UTC
While installing RHEL 7.4 Beta, I noticed that Anaconda suggests http://redhat.com/forgot_password to recover the subscription password. While it does get redirected to a HTTPS host, it might be a tad nicer.

Comment 2 Martin Kolman 2017-05-31 15:03:58 UTC
Which screen shows that URL ? The Subscription Manager screen after the installation (in Initial Setup) or some screen in Anaconda during the installation ?

Comment 3 Debarshi Ray 2017-05-31 15:14:12 UTC
(In reply to Martin Kolman from comment #2)
> Which screen shows that URL ? The Subscription Manager screen after the
> installation (in Initial Setup) or some screen in Anaconda during the
> installation ?

Yes, it was Initial Setup. Sorry, I might have spoken too fast when I mentioned Anaconda.

(In reply to Debarshi Ray from comment #0)
> While it does get redirected to a HTTPS host, it might be a tad nicer.

... tad nicer to show 'https' in the UI.

(Embarassed that I forgot to complete the sentence.)

Comment 4 Martin Kolman 2017-05-31 15:30:07 UTC
(In reply to Debarshi Ray from comment #3)
> (In reply to Martin Kolman from comment #2)
> > Which screen shows that URL ? The Subscription Manager screen after the
> > installation (in Initial Setup) or some screen in Anaconda during the
> > installation ?
> 
> Yes, it was Initial Setup. Sorry, I might have spoken too fast when I
> mentioned Anaconda.
So in that case it's in the Subscription Manager addon - that's what provides then Subscription Manager screen visible in Initial setup. So reassigning this bug to them.

> 
> (In reply to Debarshi Ray from comment #0)
> > While it does get redirected to a HTTPS host, it might be a tad nicer.
> 
> ... tad nicer to show 'https' in the UI.
> 
> (Embarassed that I forgot to complete the sentence.)
No problem. :)

Comment 6 Rehana 2017-11-10 07:51:22 UTC
Reproduced failure on RHEL74, with the following version 
subscription-manager: 1.19.21-1.el7
python-rhsm: 1.19.9-1.el7

Reproduced that the "Tip: Forgot your username or password  ?" was pointing to http://redhat.com/forgot_password (RHEL74reproducer.png)


Verifying on latest build RHEL75 build , 
=======================================

subscription-manager-rhsm-certificates-1.20.5-1.el7.x86_64
subscription-manager-gui-1.20.5-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.5-1.el7.x86_64
subscription-manager-migration-data-2.0.37-1.el7.noarch
subscription-manager-1.20.5-1.el7.x86_64
subscription-manager-rhsm-1.20.5-1.el7.x86_64
subscription-manager-migration-1.20.5-1.el7.x86_64


Observed that now the "Tip: Forgot your username or password  ?" is pointing to https://redhat.com/forgot_password on both initial-setup registration screen and as well as on the subscription-manager-gui register screen.

PFA RHEL75-reproducer.png and register_screen.png

Marking this bug as "Verified"

Comment 7 Rehana 2017-11-10 07:52:00 UTC
Created attachment 1350340 [details]
RHEL74-reproducer

Comment 8 Rehana 2017-11-10 07:54:10 UTC
Created attachment 1350341 [details]
RHEL75-fixed

Comment 9 Rehana 2017-11-10 07:55:09 UTC
Created attachment 1350342 [details]
register_screen

Comment 12 errata-xmlrpc 2018-04-10 09:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.