This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 145737 - httpd-manual package is missing
httpd-manual package is missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 18:24 EST by Andrei Ivanov
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 06:46:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrei Ivanov 2005-01-20 18:24:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1)
Gecko/20020719 Netscape/7.0

Description of problem:
There is no httpd-manual package available
(although the whole /manual/ subtree is still present in source
.tar.gz file in the .src.rpm).

Version-Release number of selected component (if applicable):
httpd-2.0.46-44.ent

How reproducible:
Always

Steps to Reproduce:
1. On the RHEL3u4/WS installation CD 3 there are just three packages
   - httpd-2.0.46-44.ent.i386.rpm,
   - httpd-devel-2.0.46-44.ent.i386.rpm,
   - mod_ssl-2.0.46-44.ent.i386.rpm.

    

Expected Results:
4th related package - httpd-manual-2.0.46-44.ent.i386.rpm

Additional info:
Comment 1 Joe Orton 2005-01-21 06:46:31 EST
Thanks for contacting us.  From RHEL3 onwards, the httpd manual is no
longer redistributed in packaged form.  The Apache website has an
always-up-to-date copy of the 2.0 documentation:

http://httpd.apache.org/docs-2.0/
Comment 2 Andrei Ivanov 2005-01-21 13:58:55 EST
Is there some logical explanation why that was decided so?
The .src.rpm still contains all the manuals, and you're just
avoiding the -manual subpackage. User should have local access
to documentation, corresponding to the version of software
installed on his system, not necessarily to the latest vesrion
of the manual on the web (which may be inaccessible for some
reason(s)).
Comment 3 Joe Orton 2005-01-21 14:46:55 EST
Sure, it's trade-off:

- PRO: always accessible local copy
- CON: local copy isn't usable anyway if local httpd isn't running due
to use of typemap files for .html
- CON: size (ever-increasing as more translations are added upstream)
- CON: continually out-of-date/maintenance burdern

The upstream manual does address versioning concerns, any features
only present in say 2.0.49 will be marked as such.

The RHEL manuals do also cover Apache configuration.

It's also easy to set up a caching reverse proxy to the upstream
sources, i.e.:

ProxyPass /manual http://httpd.apache.org/docs-2.0/
# ... + caching setup
Comment 4 Andrei Ivanov 2005-01-24 15:13:16 EST
> The upstream manual does address versioning concerns, any features
> only present in say 2.0.49 will be marked as such.

Because RedHat rather often backports new features to previous stable
versions of packages, sometimes it's hard to say which feature set
is available with this particular package.

And in all cases documentation should be available locally (no matter
how easy it can be found on the web. In Apache's case I personally
have some doubts about reliablility of the .org TLD.)

RedHat has commited to support RHEL3 for 5 years, till the end of
2008, or so. What if Apache project will cease to exist in December,
2005 [for example]?
Comment 5 Joe Orton 2005-01-25 11:29:08 EST
Oh, please accept my apologies, I need to eat humble pie: the -manual
package is actually included again from RHEL4!  I'm not sure there's
motivation to reverse this for RHEL3.   It does not address your
requirement that backported features are versioned appropriately.

echo rsync -aqz --cvs-exclude rsync.apache.org::httpd-site/docs-2.0/
/var/www/manual/ > /etc/cron.daily/httpd-manual

?

Note You need to log in before you can comment on or make changes to this bug.