Bug 145748 - hald isn't restarting automagically after 0.4.6 upgrade is installed.
hald isn't restarting automagically after 0.4.6 upgrade is installed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 21:06 EST by Jef Spaleta
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 12:44:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-01-20 21:06:15 EST
Description of problem:
hal-0.4.5  installed and running
upgrade to the new hal-0.4.6 packages just released to
updates-released tree for fedora core 3 and hald is not restarted.

old packages:
hal-devel-0.4.5-1.FC3.i386.rpm  
hal-0.4.5-1.FC3.i386.rpm        
hal-gnome-0.4.5-1.FC3.i386.rpm  

new packages:
hal-devel-0.4.6-1.FC3.i386.rpm
hal-0.4.6-1.FC3.i386.rpm
hal-gnome-0.4.6-1.FC3.i386.rpm

Could this be the result of a missing /sbin/  in the package scriptlets? 

Should that be /sbin/service haldaemon instead of just
service haldaemon?


How reproducible:
Everytime i do the upgrade from 0.4.5 to 0.4.6 rpms. up2date,yum and
rpm -Uvh

Steps to Reproduce:
1. check to make sure hald is running and hal 0.4.5 rpm are installed
2. upgrade to hal 0.4.6 wait a minute 
3. check to make sure hald is running and it isnt.
  


Expected results:
I would have thought hald would be restarted after package upgrade.


Do you need any logging information?
Comment 1 David Zeuthen 2005-01-21 11:04:04 EST
It should definitely be /sbin/service instead of just service - I
haven't seen this before but I have fixed the package; please try

 http://people.redhat.com/davidz/hal-cvs20050121/

and let me know if it fixes this bug.

Thanks,
David
Comment 2 Jef Spaleta 2005-01-21 11:16:15 EST
i just updated from 0.4.6-1  to the 0.4.6.cvs20050121-1  set

still saw the same behavior.  hald was stopped but not restarted.
Are you seeing similar behavior?  Maybe my hald is flaking out for
some other reason besides the service commands?  Or maybe the lack of
/sbin/ in the installed 0.4.6-1 scriplets affected the upgrade still.
The /sbin was missing from both the preuninstall and the postuninstall
in 0.4.6-1 so it might not work unless the installed AND the upgrade
both have /sbin in the scripts.

I did an rpm -Uvh --force of the 0.4.6.cvs20050121-1 set while they
were the 0.4.6.cvs20050121-1 was installed and hald is running.

Just to make sure the missing /sbin from the 0.4.6-1 scripts was the
problem.  Can you spin up 0.4.6.cvs20050121-2 package set?  I want to
see if upgrading from 0.4.6.cvs20050121-1  with the /sbin fix works if
i upgrade to 0.4.6.cvs20050121-2 with the /sbin fix.


-jef
Comment 3 David Zeuthen 2005-01-21 11:21:34 EST
Hi,

I've respun and the packages are here

 http://people.redhat.com/davidz/hal-cvs20050121/2/

Cheers,
David
Comment 4 Jef Spaleta 2005-01-21 11:31:42 EST
okay just did the -2 update from -1   hald still ended up stopping.
I'm going have to put hald in verbose mode i think and see if i can
log whats going on later tonite when im home. 



-jef

Comment 5 Jef Spaleta 2005-01-21 18:56:10 EST
Bah.. i dont think i can log this effectively.

If i run:    
/usr/sbin/hald --daemon=no --verbose=yes >/tmp/hal-log.txt 2>&1

the upgrade to the -2 packages doesn't cause hald to shutdown. And it
shouldn't since the service call isn't stopping hal since no pid file
was created from a service start call.

So i simply tried doing an /sbin/service haldaemon condrestart
and it failed! I dont think the sleep 3 is a long enough wait for hald
to cleanly stop.  I replaced sleep 3 with sleep 10  still failed.
sleep 20 however  worked.

Anything you need me to poke at now?  I definitely think the problem
is with the condrestart. The stop just takes +10 seconds to do a full
service shutdown on my system and hence the ssrvice start doesn't
actually happen.

-jef

Comment 6 Jef Spaleta 2005-01-21 19:09:49 EST
okay just double checked with a second system and  it does not see the
problem. The affected system is an smp machine  while the system that
works as expected is a single processor machine. Don't know if that
matters.  Tried to get a few people to reprodce it on irc.. and no one
can.  I'm willing to chalk this up to a busted system on my end, but
it would be nice to understand why its taking hal this long to shutdown.

Anything you can think of for me to poke at?

-jef
Comment 7 Tom Wood 2005-02-01 08:03:07 EST
hal-0.4.7-1-FC3 still fails for me.  Running /usr/sbin/hald
--daemon=no --verbose=yes segfaults.  Single processor Athlon/KT133
chipset that was stable under RH9.
Comment 8 David Zeuthen 2005-03-21 12:44:30 EST
This should be fixed in the 0.5.0 series; please reopen this bug if it still fails

Note You need to log in before you can comment on or make changes to this bug.