Bug 145750 - HAL doesn't list info.capabilites for some (all?) PCMCIA network cards
HAL doesn't list info.capabilites for some (all?) PCMCIA network cards
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 21:15 EST by Rodd Clarkson
Modified: 2013-03-05 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-24 23:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from 'lshal &> /tmp/lshal.output' (32.63 KB, text/plain)
2005-01-23 07:06 EST, Rodd Clarkson
no flags Details

  None (edit)
Description Rodd Clarkson 2005-01-20 21:15:13 EST
Description of problem:

HAL doesn't list info.capabilites for my PCMCIA network cards (RT-2400
and RT-2500).  As a result, Network Manager is unaware of the
existence of these network devices.

As I understand it, HAL (using either hal-device-manager or pshal)
should show an entry something like

	info.cababilities	string	net.80211 net

for PCMCIA cards.  Unfortunately, HAL doesn't even show this 'field',
let alone that the card has network type capabilites.
Comment 1 David Zeuthen 2005-01-21 11:01:32 EST
Hi,

yeah, this stopped working when the sysfs patch for PCMCIA cards was
introduced somewhere in 2.6.10; it worked fine under 2.6.9. Please try
the new packages here

 http://people.redhat.com/davidz/hal-cvs20050121/

that should fix the problem.

Thanks,
David
Comment 2 Rodd Clarkson 2005-01-23 07:03:31 EST
This didn't work for me.

Regarding you comment above that suggests this is a regression, this
has never worked for me.  This is not (AFAIK) a regression.  At no
time that I'm aware of has HAL reported these cards as having
info.capabilites.  Certainly not during the 2.6.9 kernels anyway.

I'm still not seeing any info.capabilities for this card.  I'll attach
the output from pshal so that you can see what I'm getting.
Comment 3 Rodd Clarkson 2005-01-23 07:06:01 EST
Created attachment 110104 [details]
output from 'lshal &> /tmp/lshal.output'
Comment 4 Rodd Clarkson 2005-01-23 07:08:01 EST
Oh, that should have been lshal, not pshal.

Also, the card(s) in questions show up in the section for pci.vendor =
'RaLink' (string) to make it easier to find.  As mentioned, it should
have a info.capabilities entry that says it's a wireless network card.
Comment 5 David Zeuthen 2005-01-23 10:05:53 EST
It seems that your card is _Cardbus_ (e.g. the kernel sees it as just
another PCI device) and not a 16-bit PCMCIA card. Here's a short
explanation

 http://en.wikipedia.org/wiki/PCMCIA

So, it seems that you are simply missing the driver. Hence, this is
not a hal bug and it explains why it has never worked for you. It
seems there is a driver you can use here

 http://www.bb-zone.com/misc/rt2500/

but the usual disclaimers apply (e.g. if it breaks anything, you get
to keep both pieces).

Since I've tested this myself on a Cisco 16-bit PCMCIA card using the
airo driver, I'm going to close this bug when the fixed package is
uploaded.

David
Comment 6 Rodd Clarkson 2005-01-24 23:13:40 EST
Okay.  I was using the driver us mention at the time of filing this
bug.  I've since upgraded to the current beta release of the new driver.

Neither driver sees the card being reported by HAL as having
info.capabilities.

If this is a driver issue, could you tell me what the driver is
supposed to be doing so that HAL will know what the device can do. 
Some site or something that I can point the driver developers to that
they could use as a reference.
Comment 7 Rodd Clarkson 2005-01-24 23:16:25 EST
Reopening bug because the problem hasn't actually been resolved for me.
Comment 8 David Zeuthen 2005-01-24 23:21:42 EST
Did I not make myself clear in comment 5? This is a _driver issue_,
not a hal issue, so it makes little sense to reopen this bug.

As to solving your problem, check that the directory

 /sys/class/net/eth0

contains two symlinks called device and driver (replace eth0 with the
name of the device; /var/log/messages may be helpful here). If it
doesn't go bug the driver authors; it's pretty easy to fix (just a
SET_NETDEV_DEV macro IIRC).

Note You need to log in before you can comment on or make changes to this bug.