Bug 145752 - Build Liferea against Firefox instead of Mozilla
Build Liferea against Firefox instead of Mozilla
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-20 21:23 EST by Robert Locke
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.19-3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 17:21:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Locke 2005-01-20 21:23:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Installation of the rpm fails asking for the following files:
error: Failed dependencies:
        libgtkembedmoz.so is needed by liferea-0.6.4-1.b.i386
        libxpcom.so is needed by liferea-0.6.4-1.b.i386
To resolve dependency, yum chooses to suggest installation of Mozilla.
 This is an FC3 installation that is using Firefox.  Both files could
already be found in /usr/lib/firefox-1.0/ directory.  Why require
installation of mozilla 1.7.3?

Version-Release number of selected component (if applicable):
liferea-0.6.4-1.b

How reproducible:
Always

Steps to Reproduce:
1. Install fresh FC3 with only firefox 1.0, not mozilla...
2. Download rpm from Fedora Pre-Extras
3. rpm -ivh liferea-0.6.4-1.b.i386.rpm
    

Actual Results:  Installation fails, with missing dependencies....

Expected Results:  Package should install... :-)

Additional info:
Comment 1 Brian Pepple 2005-01-20 22:18:19 EST
The main reason were using Mozilla to build the Mozilla plugin, is
because we're tracking the upstream package.  In addition, I'm not
even sure that there is a firefox-devel package to build against
currently in FC3.
Comment 2 Michael Schwendt 2005-01-22 19:35:46 EST
> Both files could already be found in /usr/lib/firefox-1.0/
> directory.  Why require installation of mozilla 1.7.3?

Because actually the gecko runtime environment is only provided by the
mozilla package:

$ rpm --redhatprovides libgtkembedmoz.so libxpcom.so
mozilla-1.7.3-17
mozilla-1.7.3-17

A few other packages also depend on it:

$ rpm --redhatrequires libgtkembedmoz.so libxpcom.so
devhelp-0.9.2-2
epiphany-1.4.4-4
devhelp-0.9.2-2
epiphany-1.4.4-4
mozilla-1.7.3-17
mozilla-devel-1.7.3-17
mozilla-dom-inspector-1.7.3-17
mozilla-mail-1.7.3-17

Currently, the only way out would be to split off a liferea-mozilla
package for just the 15K small gecko/mozilla rendering plugin. Not
worthwhile for FC3. But could be reconsidered for FC4 if nothing
changes with regard to the gecko provider (we build against
mozilla-devel, too).
Comment 3 Robert Locke 2005-01-25 09:21:58 EST
Is it perhaps a change in the packaging of firefox-1.0 that I am
requesting then?  To have the package admit that it is
installing/providing those particular files?  What I mean is, I only
have firefox installed at the moment, and those particular files being
requested can both be found in /usr/lib/firefox-1.0/.  What I am
apparently being dense about, is why can't liferea and the others like
epiphany simply be happy with what firefox is providing?  I guess I am
not understanding the statements of building against mozilla-devel,
perhaps.  Thanks for your patience.
Comment 4 Michael Schwendt 2005-01-25 09:58:52 EST
Yes, what you have in mind is not available [yet].

The Gecko engine is only provided by the mozilla packages. Hence we
build against 'mozilla-devel', and the automatic dependencies are
satisfied by the 'mozilla' package. The firefox packages as found in
Fedora Core do not supply Gecko development files (no firefox-devel
package) and neither the Gecko Runtime Environment as shown in comment 2.

Btw, I've talked to Dag Wieers, who also provides a liferea package,
and he is not fond of a liferea-mozilla split-off either. Means we
will very likely release the 0.9.0b update as found in Fedora Extras
CVS unchanged.
Comment 5 Brian Pepple 2005-01-25 10:44:45 EST
Wasn't there talk awhile back, about Mozilla separating the libraries
into a serarate package like libmozilla?  I vaguely remember reading
something about it last year, but since I don't keep a close eye on
Mozilla developement I not 100% sure.
Comment 6 Brian Pepple 2005-05-09 13:04:19 EDT
Here's a further update on library separation:
https://www.redhat.com/archives/fedora-devel-list/2005-May/msg00105.html
Comment 7 Brian Pepple 2006-07-31 11:18:50 EDT
Looks like there is a firefox-devel package in Rawhide now, so once FC6T2 comes
out and I get it installed, I'll start building liferea against that.
Comment 8 Brian Pepple 2006-08-07 17:21:34 EDT
Liferea is being built against firefox as of version 1.0.19 in devel.

Note You need to log in before you can comment on or make changes to this bug.