Bug 145762 - Mount picks wrong "LABEL="-specified partition if >1 HDDs present
Mount picks wrong "LABEL="-specified partition if >1 HDDs present
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-21 04:18 EST by Dmitry Bolkhovityanov
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:41:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Bolkhovityanov 2005-01-21 04:19:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021203

Description of problem:
For some years RedHat's installer lists partitions in /etc/fstab as
"LABEL=" instead of "/dev/hda*" or "/dev/sda*".  This works fine while
the set of HDDs is constant.

BUT: when one adds another drive from a similar computer (for copying,
backup, maintenance, rescue, etc.), the "LABEL=" stuff prevents normal
operation.  For some strange reason, instead of mounting FIRST
partition which has requested label, mount uses LAST one.

This either makes such disk-swapping impossible, or forces a user to
touch /etc/fstab, listing there /dev/hda* instead of "LABEL="s.

In either case, such behaviour is very inconvenient, and seems to be
absolutely unjustified and useless.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install two identical systems, let's name them Bonnie and Clyde, so
that /usr is on a separate partition, e.g. /dev/hda5.
2. Move Clyde's HDD to Bonnie, so that it becomes /dev/hdb
3. Boot the system
    

Actual Results:  /usr is mounted from /dev/hdb5 -- i.e., 2nd
(originally Clyde's) drive.

Expected Results:  /usr should be mounted from /dev/hda5.

Additional info:

Bug #101570 suggests that this can be a kernel's bug, but for me as a
user, it is mount's bug, and since I'm not an expert in this area, I
file a bugreport against util-linux.
Comment 1 Elliot Lee 2005-03-02 17:26:54 EST
I believe mount is supposed to just plain balk in this case...
Comment 2 Karel Zak 2005-03-30 06:01:33 EST
I think answer from mount should be error message 'duplicate - not mounted'.
There is no reason why the mount command should be mount first or last HDD if
there is duplicate LABEL.

In FC4 should be available workaround that allows to define priority of
duplicate LABELs in file /etc/fstab.order.
Comment 3 Karel Zak 2005-09-08 06:41:02 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Note You need to log in before you can comment on or make changes to this bug.