Bug 1457658 - Cloned role has no builtin value
Summary: Cloned role has no builtin value
Keywords:
Status: CLOSED DUPLICATE of bug 1353788
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Authorization
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-01 06:26 UTC by Shimon Shtein
Modified: 2017-06-12 13:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-12 13:46:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 3917 None None None 2017-06-02 16:46:42 UTC

Description Shimon Shtein 2017-06-01 06:26:59 UTC
Creating a new role from the Administer table by cloning an existing role results in no value being entered into the 'builtin' field. This makes the role non selectable in the user and groups menus and not deletable. Work around is to update the roles table directly eg: "update roles set builtin = 0 where id = xx;".

Note: This is 1.11.2 which is not selectable below so please accept my apologies if this has been fixed in 1.11.3

Comment 1 Shimon Shtein 2017-06-01 06:27:04 UTC
Created from redmine issue http://projects.theforeman.org/issues/15108

Comment 3 Marek Hulan 2017-06-01 06:45:28 UTC
Shim, I think this was fixed in 6.2.9 by BZ 1353788, can you still reproduce with this version?

Comment 4 pm-sat@redhat.com 2017-06-01 08:08:32 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/15108 has been resolved.


Note You need to log in before you can comment on or make changes to this bug.