Bug 145779 - tracback from satellite-sync for large network sync
tracback from satellite-sync for large network sync
Status: CLOSED DUPLICATE of bug 146229
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
360
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
:
Depends On:
Blocks: 147692
  Show dependency treegraph
 
Reported: 2005-01-21 10:29 EST by nathan r. hruby
Modified: 2007-07-31 11:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nathan r. hruby 2005-01-21 10:29:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Hi,

Last night I attempted to live sync over the network the following
distributions:
16:02:56       . rhel-i386-desktop-3                      1983
16:02:56       . rhel-ia64-as-3                           2671
16:02:56       . rhel-ia64-es-3                           2206
16:02:56       . rhel-ia64-ws-3                           2645
16:02:56       . rhel-ppc-as-3                            2798
16:02:56       . rhel-x86_64-as-3                         2798
16:02:56       . rhel-x86_64-desktop-3                    2189
16:02:56       . rhel-x86_64-es-3                         2301
16:02:56       . rhel-x86_64-ws-3                         2768

Donloading of RPM's, package metadata, errata data, kickstart tree
metadata, kickstart tree files went well.. Sadly at the "Importing
channel errata" step a traceback was thrown as shown below:

---- BEGIN TRACEBACK
04:35:05 Linking packages to channels
04:35:44 No handler for step source-packages
04:35:44 
04:35:44 Importing channel errata
04:35:53    Importing *relevant* errata: rhel-x86_64-ws-3 (387)
04:56:36 
SYNC ERROR: unhandled exception occurred:

Exception reported from sputnik.cc.uga.edu
Time: Fri Jan 21 04:56:36 2005
Exception type server.rhnSQL.sql_base.SQLError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 134, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 154, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 258, in
_step_errata
    self.syncer.import_errata()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1659, in
import_errata
    sync_handlers.import_errata(chunk)
  File "/usr/share/rhn/satellite_tools/sync_handlers.py", line 403, in
import_errata
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 541, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/errataImport.py", line 164, in
submit
    self._fix_files()
  File "/usr/share/rhn/server/importlib/errataImport.py", line 159, in
_fix_files
    ['errata_file_id', 'channel_id'], [])
  File "/usr/share/rhn/server/importlib/backend.py", line 1324, in
_do_diff
    apply(h.executemany, (), params)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 102, in
executemany
    return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 131, in
_execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (30036, 'ORA-30036: unable to extend segment by 8 in undo
tablespace
\'UNDO_TBS\'\nORA-06512: at "RHNSAT.RHN_ERRATA_MOD_TRIG", line
40\nORA-04088: error during
execution of trigger \'RHNSAT.RHN_ERRATA_MOD_TRIG\'\nORA-06512: at
"RHNSAT.RHN_EFILEC_MOD_TRIG", line 25\nORA-04088: error during
execution of trigger
\'RHNSAT.RHN_EFILEC_MOD_TRIG\'\n', 'insert into rhnErrataFileChannel
(errata_file_id,
channel_id) values (:errata_file_id, :channel_id)')
---- END TRACEBACK

Suggest either making undo logs bigger or limiting the number of base
distros satellite-sync can process in a single invocation.

Version-Release number of selected component (if applicable):
Sat 3.6.0 embedded

How reproducible:
Didn't try

Steps to Reproduce:
1. Import many base channels on embedded Satellite with satellite sync
2. See if satellite-sync give a traceback about undo logs
    

Actual Results:  traceback at erratta import step

Expected Results:  satellite-sync runs to compltetion, importing all
request channels

Additional info:
Comment 1 Todd Sanders 2005-02-10 13:41:45 EST

*** This bug has been marked as a duplicate of 146229 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.