Bug 1457810 - Fix logging issue in engine-config under EAP 7.0.6
Summary: Fix logging issue in engine-config under EAP 7.0.6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Martin Perina
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks: 1457900 1458842
TreeView+ depends on / blocked
 
Reported: 2017-06-01 10:58 UTC by Martin Perina
Modified: 2019-05-16 13:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1457900 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:42:49 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:44:33 UTC
oVirt gerrit 77640 0 master MERGED core: Include jcl-over-slf4j into tools modules 2020-06-30 17:22:31 UTC

Description Martin Perina 2017-06-01 10:58:32 UTC
Description of problem:

Apache commons-logging libraries are reimplemented within WildFly EAP​. In 7.0.5 and previous versions the reimplementation has been provided by 'org.slf4j.jcl-over-slf4j' module, in 7.0.6 reimplementation has been changed to 'org.jboss.logmanager.commons.logging'.

This works fine if application is executed inside running EAP, but we are using those libraries also outside running EAP in command line tools. In order to be able to use slf4j as our logging frontend we are using standard slf4j implementation instead of EAP reimplementation of slf4j for our command line tools. Apache commons-logging is used indirectly through apache-commons-configuration also in command line tool engine-config, so we would need
to add 'org.slf4j.jcl-over-slf4j' into our special modules for command line tools to override this reimplementation change.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run engine-config -a
2.
3.

Actual results:

null

Expected results:

List all available engine-config options

Additional info:

Comment 3 Lucie Leistnerova 2017-11-07 10:34:42 UTC
'engine-config -a' prints available options

verified in ovirt-engine-4.2.0-0.0.master.20171105155215.git59d3324.el7.centos.noarch

Comment 6 errata-xmlrpc 2018-05-15 17:42:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 7 Franta Kust 2019-05-16 13:07:05 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.