Bug 1457827 - Changes to the voting system on glusterfs 'master' branch
Summary: Changes to the voting system on glusterfs 'master' branch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-01 11:51 UTC by Amar Tumballi
Modified: 2017-06-20 06:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-20 06:09:41 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2017-06-01 11:51:14 UTC
Description of problem:

Only for 'master' branch:

- make the overall regression lightweight.
  - Run what netbsd tests run now for CentOS regression (ie, basic and features in tests) - will mostly take just <2hrs.
  - Don't run netbsd builds
  - Instead add a compilation test on centos 32bit machine to keep reminding ourself how many warnings we get. (And compilation failure there is -1).


On release-x.y branch:

- Continue with the currently existing voting rights, and the tests would be different. (ie, full regression instead of lightweight regression tests).


More info on this is found @ http://lists.gluster.org/pipermail/maintainers/2017-May/002587.html

Comment 1 Nigel Babu 2017-06-05 04:25:16 UTC
On master:

1) I'm thinking we just run the tests/basic folder?
2) Do you mean netbsd builds or regressions? The netbsd build (netbsd6-smoke) itself takes a short duration and is trivial to run. I recommend we keep that remove the NetBSD voting job. Additionally, are we running the netbsd regressions on a nightly basis now?
3) We already have a 32-bit compilation test in the form of strfmt_errors. Do we want more?


On release branch:

As far as I can see, this seems to be "keep going as we do right now". Are we removing netbsd voting regressions here too?

Comment 2 Amar Tumballi 2017-06-05 04:41:59 UTC
for 'master':

1) tests/basic is good.

2) lets run netbsd6-smoke 

3) We can run 'netbsd' job in nightly IMO. (doesn't matter much on 'master' branch decision now).


On 'release-x.y':

* For now, lets keep going as is, and see if any changes required later.

Comment 3 Nigel Babu 2017-06-20 06:09:41 UTC
All the changes have been made today.


Note You need to log in before you can comment on or make changes to this bug.