Bug 1457963 - rpcbind.service entered failed state
Summary: rpcbind.service entered failed state
Status: CLOSED DUPLICATE of bug 1454876
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: x86_64 Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-01 15:55 UTC by pcamps
Modified: 2017-06-20 08:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-15 15:58:07 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pcamps 2017-06-01 15:55:00 UTC
Description of problem:
Clients can not mount NFS 3 protocol after I updated rpcbind. But clients can mount NFS 4 protocol.

Version-Release number of selected component (if applicable):
rpcbind-0.2.0-38.el7_3.x86_64.rpm

How reproducible:
Mounting NFS 3 with mount command. 


Steps to Reproduce:
1.  On the client :
    # mount -t nfs -o vers=3 nfsserver:/directory/nfsv3/centOS /mnt/nfs
mount.nfs: requested NFS version or transport protocol is not supported

2. On NFS server, verify the rpcbind status :
   "systemctl status rpcbind" is "active"
   "systemctl status rpcbind.socket" is "active"


3. /var/log/messages shows the issue :
   systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
   Unit rpcbind.service entered failed state.
   rpcbind.service failed.

4. Try the command : "showmount -a"
   rpcbind.service failed.

5. Restart nfs-server : systemctl restart nfs-server

6. Verify the issue disappeared

7. Verify the issue restarted in the hour :

Jun  1 08:13:49 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 08:13:49 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 08:13:49 garbin systemd: rpcbind.service failed.
Jun  1 09:13:49 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 09:13:49 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 09:13:49 garbin systemd: rpcbind.service failed.
Jun  1 10:13:49 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 10:13:49 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 10:13:49 garbin systemd: rpcbind.service failed.
Jun  1 11:13:50 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 11:13:50 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 11:13:50 garbin systemd: rpcbind.service failed.
Jun  1 12:13:50 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 12:13:50 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 12:13:50 garbin systemd: rpcbind.service failed.
Jun  1 13:13:51 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 13:13:51 garbin systemd: Unit rpcbind.service entered failed state.
Jun  1 13:13:51 garbin systemd: rpcbind.service failed.
Jun  1 14:13:51 garbin systemd: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun  1 14:13:51 garbin systemd: Unit rpcbind.service entered failed state.

etc ...
    
Actual results:
I removed rpcbind program and reinstalled the previous version
    Jun 01 15:33:04 Erased: rpcbind-0.2.0-38.el7_3.x86_64
    Jun 01 15:33:31 Installed: rpcbind-0.2.0-38.el7.x86_64
    Jun 01 15:38:02 Installed: 1:quota-4.01-14.el7.x86_64
    Jun 01 15:38:03 Installed: 1:nfs-utils-1.3.0-0.33.el7_3.x86_64


Expected results:
It works now with the previous version

Additional info:
I saw the : Bug 1402961 - rpcbind.socket systemd unit fails to start when IPv6 is disabled. 
I have IPV6. I disabled IPV6 with : net.ipv6.conf.all.disable_ipv6 = 1
I reboot. No changes with the issue. 
I enable again IPV6

Comment 3 Chris Schanzle 2017-06-06 01:03:34 UTC
When probed by our Tenable scanner, our rpcbind's are dieing as well, taking ypbind and nfs-service 
[edited IP's and abbreviated FQDN's]

Failed:
journalctl 
Jun 05 11:42:21.333172 [dradis] rpc.mountd[1329]: refused mount request from 129.6.x.y for /local/hev (/local/hev): unmatched host
Jun 05 11:42:21.376573 [dradis] rpc.mountd[1329]: refused mount request from 129.6.x.y for /local/hev (/local/hev): unmatched host
Jun 05 11:42:21.405549 [dradis] rpcbind[3503]: connect from 129.6.x.y to set(mountd): indirect call not allowed
Jun 05 11:42:21.406190 [dradis] systemd[1]: rpcbind.service: main process exited, code=killed, status=6/ABRT
Jun 05 11:42:21.406440 [dradis] systemd[1]: Unit rpcbind.service entered failed state.
Jun 05 11:42:21.406474 [dradis] systemd[1]: rpcbind.service failed. 

rpm -q rpcbind ypbind kernel nfs-utils
rpcbind-0.2.0-38.el7_3.x86_64
ypbind-1.37.1-7.el7.x86_64
kernel-3.10.0-514.16.1.el7.x86_64
kernel-3.10.0-514.21.1.el7.x86_64
nfs-utils-1.3.0-0.33.el7_3.x86_64


Survived:

Jun 05 11:38:49.358215 [yooper] rpc.mountd[1177]: refused mount request from 129.6.x.z for /local/home (/local/home): unmatched host
Jun 05 11:38:49.380800 [yooper] rpc.mountd[1177]: refused mount request from 129.6.x.z for /local/home (/local/home): unmatched host
Jun 05 11:38:49.389327 [yooper] rpcbind[20931]: connect from 129.6.x.z to set(mountd): indirect call not allowed
Jun 05 11:38:49.444699 [yooper] rpc.mountd[1177]: refused mount request from 129.6.x.z for /local/home (/local/home): unmatched host
Jun 05 11:38:49.503983 [yooper] rpc.mountd[1177]: refused mount request from 129.6.x.z for /local/home (/local/home): unmatched host
Jun 05 11:39:25.466353 [yooper] rpc.mountd[1177]: authenticated mount request from [ogre]:897 for /local/home (/local/home)

rpm -q rpcbind ypbind kernel nfs-utils
rpcbind-0.2.0-38.el7.x86_64
ypbind-1.37.1-7.el7.x86_64
kernel-3.10.0-514.10.2.el7.x86_64
kernel-3.10.0-514.16.1.el7.x86_64
nfs-utils-1.3.0-0.33.el7_3.x86_64

Comment 4 Steve Dickson 2017-06-15 15:58:07 UTC

*** This bug has been marked as a duplicate of bug 1454876 ***


Note You need to log in before you can comment on or make changes to this bug.