Bug 145801 - modem_run hangs in latest errata kernels due to usb changes
modem_run hangs in latest errata kernels due to usb changes
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-21 13:55 EST by P P Anwar
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:08:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Candidate #1 (3.29 KB, patch)
2005-01-31 22:10 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description P P Anwar 2005-01-21 13:55:29 EST
Description of problem:

The kernel seems to include usb changes that causes issues with some
programs, specifically the modem_run program used for uploading
firmware to the Thompson/Alcatel Speedtouch USB modems.  The issue is
discussed in detail at 

http://sourceforge.net/mailarchive/forum.php?thread_id=6054671&forum_id=5398

I have tried applying the patch mentioned in that thread to the Errata
3 kernels, and modem_run works fine after applying the patch.  Would
you be introducing the fix mentioned in that thread to an upcoming
kernel errata release, or would we be forced to manualyl patch it
ourselves ?

Version-Release number of selected component (if applicable):
2.4.21-27.0.2

How reproducible:
Every time.

Steps to Reproduce:
1. Try to install speedtouchconf from speedtouchconf.sf.net by running
"speedtouchconf.sh".  It hangs midway through, with the modem light
staying at amber after couple of green blinks.  
2. The process listing shows that modem_run is the program that is
hanging.
3. Can be reproduced at will by running "modem_run" by hand.
  
Actual results:
1. modem_run hangs.

Expected results:
modem_run completes execution and ADSL synchronization is obtained by
modem.

Additional info:
Comment 1 Pete Zaitcev 2005-01-31 22:10:20 EST
Created attachment 110479 [details]
Candidate #1

This is based on Sergey's approach, plus ENOTTY check is done
outside of the lock.
Comment 2 Pete Zaitcev 2005-03-22 21:16:27 EST
Please test kernel 2.4.21-31.EL.usbserial.3 by selecting a suitable
architecture from the following URL:
 ftp://people.redhat.com/zaitcev/rhel3usb/
Comment 3 RHEL Product and Program Management 2007-10-19 15:08:58 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.