Bug 1458169 - --force-join option is not mentioned in ipa-replica-install man page
Summary: --force-join option is not mentioned in ipa-replica-install man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-02 08:18 UTC by Abhijeet Kasurde
Modified: 2018-04-10 16:43 UTC (History)
9 users (show)

Fixed In Version: ipa-4.5.4-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 16:42:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:43:25 UTC

Description Abhijeet Kasurde 2017-06-02 08:18:36 UTC
Description of problem:
As per https://pagure.io/freeipa/c/72f0ecde783be7d304044eff60c8c85e160d65d8 , '--force-join' option is introduced in ipa-replica-install command, this option is not mentioned in ipa-replica-install man page

Version-Release number of selected component (if applicable):
ipa-server-4.5.0-14.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. man ipa-replica-install 
2. Search for --force-join

Actual results:
Documentation does not mention about --force-join.

Expected results:
Documentation should explain about --force-join

Comment 3 Petr Vobornik 2017-06-09 15:52:11 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7011

Comment 4 Martin Bašti 2017-06-15 11:57:25 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/7fd2102a78f2e008f2cd5fe68e9be58ead914b35

Comment 6 Florence Blanc-Renaud 2018-01-12 15:32:52 UTC
Moving to ASSIGNED as the backport was missing from ipa-4-5

Comment 7 Florence Blanc-Renaud 2018-01-12 19:44:24 UTC
Fixed upstream
ipa-4-5:
https://pagure.io/freeipa/c/56416c43b731d4accae38e2c2718767986f47d3c

Comment 11 Nikhil Dehadrai 2018-01-25 09:27:46 UTC
ipa-server-version: ipa-server-4.5.4-9.el7.x86_64

Verified the bug on the basis of following points:
1. Verified that '--force-join' option details are now available in Manual page ipa-replica-install.
2. Verified the same for plain install and upgrade scenario.

# rpm -q ipa-server
ipa-server-4.5.4-9.el7.x86_64
# man ipa-replica-install    

--force-join
              Join the host even if it is already enrolled.

Thus on the basis of above observations, marking the status of bug to 'Verified'.

Comment 14 errata-xmlrpc 2018-04-10 16:42:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.