Bug 1458196 - hammer --nondefault ignores the value passed to it and always filter out Default Organization View
Summary: hammer --nondefault ignores the value passed to it and always filter out Defa...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.2.9
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-02 09:40 UTC by Ashish Humbe
Modified: 2019-02-07 11:57 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-02-07 11:57:18 UTC


Attachments (Terms of Use)

Description Ashish Humbe 2017-06-02 09:40:58 UTC
Description of problem:

If we include --nondefault on the hammer command line when listing content views, the Default Organization View get removed regardless of what value passed to --nondefault


# hammer content-view list --organization-id=1 --nondefault yes
----------------|------------------|------------------|-----------|---------------
CONTENT VIEW ID | NAME             | LABEL            | COMPOSITE | REPOSITORY IDS
----------------|------------------|------------------|-----------|---------------
16              | test             | test             |           | 124           
33              | RHEL7tillDEC2016 | RHEL7tillDEC2016 |           | 3             
2               | RHEL7            | RHEL7            |           | 4, 3, 62      
19              | DOCKERrepos      | DOCKERrepos      |           | 4, 3, 63      
15              | CompositeView    | CompositeView    | true      |               
12              | Cartosat-2CView  | Cartosat-2CView  |           | 1, 68, 4      
6               | Atomic           | Atomic           |           | 1, 3, 32, 33  
18              | 6.7              | 6_7              |           |               
----------------|------------------|------------------|-----------|---------------

# hammer content-view list --organization-id=1 --nondefault no
----------------|------------------|------------------|-----------|---------------
CONTENT VIEW ID | NAME             | LABEL            | COMPOSITE | REPOSITORY IDS
----------------|------------------|------------------|-----------|---------------
16              | test             | test             |           | 124           
33              | RHEL7tillDEC2016 | RHEL7tillDEC2016 |           | 3             
2               | RHEL7            | RHEL7            |           | 4, 3, 62      
19              | DOCKERrepos      | DOCKERrepos      |           | 4, 3, 63      
15              | CompositeView    | CompositeView    | true      |               
12              | Cartosat-2CView  | Cartosat-2CView  |           | 1, 68, 4      
6               | Atomic           | Atomic           |           | 1, 3, 32, 33  
18              | 6.7              | 6_7              |           |               
----------------|------------------|------------------|-----------|---------------



Version-Release number of selected component (if applicable):
Red Hat Satellite v 6.2.9

How reproducible:
Always

Steps to Reproduce:
1. # hammer content-view list --organization-id=1 
2. # hammer content-view list --organization-id=1 --nondefault 0 
3. # hammer content-view list --organization-id=1 --nondefault 1

Actual results:
Always remove Default Organization View while filtering

Expected results:
When we set --nondefault No/False/0 only Default Organization View should be listed.

Additional info:

Comment 1 David Caplan 2017-06-02 15:38:26 UTC
The attribute nondefault is very ambiguous and needs to be changed as the command

hammer content-view list --organization-id=1 --nondefault yes 

or

hammer content-view list --organization-id=1 --nondefault no 

is confusing at best. 

If the goal is to display the default CV in the list then something like

hammer content-view list --organization-id=1 --default yes 

or

hammer content-view list --organization-id=1 --showdefault

Comment 3 Bryan Kearney 2018-11-30 15:00:40 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Rich Jerrido or Bryan Kearney or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 4 Bryan Kearney 2019-01-04 13:18:16 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 5 Bryan Kearney 2019-02-07 11:57:18 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.