Bug 1458553 - Don't provide all English dictionaries by default by installing hunspell-en
Summary: Don't provide all English dictionaries by default by installing hunspell-en
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell-en
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-04 11:53 UTC by Jan Vlug
Modified: 2017-06-05 19:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 19:41:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Vlug 2017-06-04 11:53:06 UTC
Description of problem:

After a fresh installation of Fedora 25 I had many English dictionaries, while I only want en-US and en-UK. As a result of all these dictionaries, there are long dropdownlistboxes in Firefox and Thunderbird when selecting a language.

It seems that all these regional variants of English are pulled in by hunspell-en.

I removed hunspell-en with dnf, which also removed hunspell-en-UK, adding hunspell-en-UK did not pull in hunspell-en.

See more details over here:
https://ask.fedoraproject.org/en/question/99140/how-can-i-get-rid-of-spellchecker-dictionaries-in-firefox/

Comment 1 Caolan McNamara 2017-06-05 19:41:14 UTC
There is a hunspell-en-US which is just en_US hunspell dicts, hunspell-en-GB for just en_GB dicts and a hunspell-en which depends on those two and provides the other variants. Its not a bug for hunspell-en to pull in the others. Its arguable if hunspell-en is in the default install but that's not the packages fault if it it. Perhaps comps or something like that does it.


Note You need to log in before you can comment on or make changes to this bug.