Bug 145857 - portmap error during boot
portmap error during boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: portmap (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 12:15 EST by Jon Roland
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 18:17:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Roland 2005-01-22 12:15:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20050104 Fedora/1.7.5-2.1.2.kde

Description of problem:
The latest upgrade seems to have removed most of the errors during
boot, but one persists. The excerpt from /var/log/messages is

portmap: portmap: error while loading shared libraries: libnsl.so.1:
failed to map segment from shared object: Permission denied
portmap: portmap startup failed

While I could fix this manually, it seems to be something that should
be fixed in packaging.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.741_FC3

How reproducible:
Always

Steps to Reproduce:
1. Boot system, note messages
2.
3.
    

Additional info:
Comment 1 Jon Roland 2005-01-23 17:31:57 EST
I got this message on the subject from the freshrpms list:

El Dom 23 Ene 2005 11:34 AM, Víctor Daniel Velasco Martínez
<vdvelascomtz@prodigy.net.mx> escribió:

>> I changed the SELinux Setting to remove the Enforce (In Permissive
Mode),
>> but still enabled, with the targeted politic, I restarted all the
services
>> requiring portmap, and it worked... I need to try on reboot, but it
seems
>> to me a SELinux problem. Testing in a second.
>>
>> V.Daniel


Yep, it is.
Comment 2 Jon Roland 2005-01-23 21:09:53 EST
Fix is to use system-config-securitylevel from root prompt to switch
the line in /etc/sysconfig/selinux from

SELINUX=enforcing

to

SELINUX=permissive

This made the portmap error go away, hopefully to reduce the problem
of drift of the system time.

But I also found that ntpd is not working to update the system clock,
so I turned it off in targeting, and that does not enable ntpd to
update the system clock, as it can on my FC2 machine on the same
network using the same ntp servers, which are accessible to a ping on
both machines. Any suggestions?
Comment 4 Daniel Walsh 2005-01-24 13:58:57 EST
If you do a

restorecon -R -v /lib /usr/lib 

This problem should go away and you can run SELinux in enforcing mode
again.

Dan
Comment 5 Jon Roland 2005-01-24 15:08:58 EST
I'll try that, but if it works it would seem to be something that
needs to be added to Anaconda.

While it may deserve to be a different bug, any ideas on why ntpd is
not working? It returns no errors. The system clock just doesn't
update, and when I run system-config-date it won't respond to any of
the ntp servers, even though I can ping them and they are working for
another machine running FC2 connected to the Net by the same router.
Comment 6 Daniel Walsh 2005-01-24 15:28:26 EST
Ok, was this an upgrade or a fresh install?  If this was an upgrade,
you will need to relabel the system.

touch /.autorelabel
reboot

ntpd failing is also probably related to shared libraries being marked
incorrectly.

Dan
Comment 7 Jon Roland 2005-01-24 15:31:16 EST
Okay, running 

restorecon -R -v /lib /usr/lib

not only seems to have fixed the portmap problem but also the ntpd
problem.

It was a fresh install.

Note You need to log in before you can comment on or make changes to this bug.