Bug 1458572 - engine-config can not set custom fencing parameters
Summary: engine-config can not set custom fencing parameters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Tools.Config
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Eli Mesika
QA Contact: David Necpal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-04 14:10 UTC by Eli Mesika
Modified: 2017-12-20 10:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:57:17 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 78720 master MERGED fix custom fencing default config setting 2017-07-02 10:06:47 UTC
oVirt gerrit 1458572 None None None 2017-06-27 15:18:46 UTC

Description Eli Mesika 2017-06-04 14:10:44 UTC
Description of problem:

Trying to set the CustomFenceAgentDefaultParams via engine-config key fails with an error 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1./engine-config -s CustomFenceAgentDefaultParams=ipmilan:lanplus;
2.
3.

Actual results:
Cannot set value ipmilan:lanplus to key CustomFenceAgentDefaultParams. The entered key value is invalid. Value should match expression '([\w]+([=][\w]+){0,1}[,]{0,1})+'. Example: agent1=key1=val1,flag;key2=val2


Expected results:
Key should be set correctly 


Additional info:

Also some getters fails , for example 

./engine-config -g FenceAgentDefaultParams
Error fetching FenceAgentDefaultParams value: no such entry. Please verify key name and property file support.


Seems a mismatch of the Regexp validator with the defined format

Comment 1 David Necpal 2017-09-04 13:39:19 UTC
Bug/problem isn't solved.

Testing on version:
ovirt-engine-4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.noarch


# engine-config -s CustomFenceAgentDefaultParams=ipmilan:lanplus;
Cannot set value ipmilan:lanplus to key CustomFenceAgentDefaultParams. The entered key value is invalid. Value should match expression '([\w]+[:]([\w]*[=][\w]*[,]{0,1}[;]{0,1}){0,3}[;]{0,1})+'. Example: agent1=key1=val1,flag;key2=val2

Comment 2 Red Hat Bugzilla Rules Engine 2017-09-04 13:39:24 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Eli Mesika 2017-09-04 14:09:42 UTC
(In reply to David Necpal from comment #1)
> Bug/problem isn't solved.
> 
> Testing on version:
> ovirt-engine-4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.noarch
> 
> 
> # engine-config -s CustomFenceAgentDefaultParams=ipmilan:lanplus;
> Cannot set value ipmilan:lanplus to key CustomFenceAgentDefaultParams. The
> entered key value is invalid. Value should match expression
> '([\w]+[:]([\w]*[=][\w]*[,]{0,1}[;]{0,1}){0,3}[;]{0,1})+'. Example:
> agent1=key1=val1,flag;key2=val2

fence-agents package changed the syntax and now we can not send Boolean keys by their own, we not to use always the format <key>=<value>

Please verify using the following syntax :

# engine-config -s CustomFenceAgentDefaultParams=ipmilan:lanplus=1;

Comment 4 David Necpal 2017-09-04 14:38:50 UTC
Verified on version:
ovirt-engine-4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.noarch

Comment 5 Sandro Bonazzola 2017-12-20 10:57:17 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.