Bug 145867 - disappearing devices
disappearing devices
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 145866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 16:03 EST by Phill O'Flynn
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 06:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phill O'Flynn 2005-01-22 16:03:35 EST
Description of problem:

background:
Earlier i reported that my winmodem would install correctly but on 
reboot the /dev/modem and /dev/ttyLTO files would disappear on 
reboot. i was told that this was a udev issue and was not a bug. 
however, i tried numerouus times to create a rule (following the 
instructions as best i could). the result is that udev would create 
an empty document for each of /dev/modem and /dev/ttyLTO.

for your information here are the rules i tried

KERNEL="ttLTM0", SYSFS{dev}="62:64", NAME="modem", SYMLINK="modem"
KERNEL="ttyLT0", SYMLINK="modem"
KERNEL="ttLTM0", NAME="modem", SYMLINK="modem"
KERNEL="ttyLT0", NAME="modem", SYMLINK="modem"

only after i use the "Modprobe lt_serial" command i could use 
udevinfo command to get information about my hardware eg

udevinfo -a -p /sys/class/tty/ttLTM0

returned:
               looking at class device '/sys/class/tty/ttLTM0':
               SYSFS{dev}="62:64"

Despite all this the character device and symbolic link are not 
created.

Finally, i purchased a dlink dfm-562e external modem. Which kudzu 
correctly detected and installed (so it would seem). /dev/modem1 is 
generated but again on subsequent reboots the character device 
drivers are no longer present.

surely this must be a bug if kudzu installs a device but the system 
looses it after reboot.

Sorry for the long entry here. i just wanted to make it as clear as 
possible what the problem was

Version-Release number of selected component (if applicable):
not sure how to find out but "up2date" is not reporting any updates 
available

How reproducible: Consistent


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sitsofe Wheeler 2005-01-23 14:42:22 EST
Looks like a dup of bug #145866
Comment 2 Phill O'Flynn 2005-01-23 16:17:36 EST
OOPS SORRY. i just used "back" on my browser to correct some wording. i 
couldn't see any other way of doing it. this one will make a bit more sense

Phill
Comment 3 Harald Hoyer 2005-01-24 06:14:59 EST
*** Bug 145866 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2005-01-25 01:02:02 EST
Long term, I suspect the solution is:
Comment 6 Bill Nottingham 2005-01-25 01:02:29 EST
Long term, I suspect the solution is:

- apps should not rely on random symlinks (such as /dev/modem)
- apps should use HAL to find their devices
Comment 7 Phill O'Flynn 2005-01-25 05:54:06 EST
i am not a linux expert. can you please explain to me how this relates
to symlinks /dev/modem and the respective character devices (even
those generated by kudzu) can be non-persistent across reboots as this
didn't seem to me to be an apps problem??
Comment 8 Phill O'Flynn 2005-01-25 05:57:03 EST
I put in a connexant chipset modem and used a linuxant driver. this
was persistent across reboots. i don't know what the difference is. I
am yet to actually get the modem to work however!
Comment 9 Harald Hoyer 2005-01-25 06:01:14 EST
>>..only after i use the "Modprobe lt_serial" command i could use 
udevinfo command to get information about my hardware eg..<<

udev only creates devices on module loading.

# echo KERNEL="ttLTM0", SYMLINK="modem" >>
/etc/udev/rules.d/10-local.rules

should do the job, after the module is loaded...

you could do:
# echo "/sbin/modprobe lt_serial" >> /etc/rc.modules
# chmod u+x /etc/rc.modules

or if you do not need it in the initscripts, load the module in
/etc/rc.local
Comment 10 Harald Hoyer 2005-01-25 06:03:14 EST
Should be 
# echo 'KERNEL="ttLTM0", SYMLINK="modem"' >>
/etc/udev/rules.d/10-local.rules
Comment 11 Phill O'Flynn 2005-01-25 20:22:40 EST
Thanks!!

Note You need to log in before you can comment on or make changes to this bug.