Bug 145873 - No Sound With Last Two FC2 Kernel Releases
No Sound With Last Two FC2 Kernel Releases
Status: CLOSED DUPLICATE of bug 144742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 17:12 EST by Richard Huelbig
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Huelbig 2005-01-22 17:12:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Here are three messages that I posted to the Fedora Forum. These
describe what I've found and what I've done. Notice that the last
message indicates that I found a workaround for the FC3 sound problem
but not for the FC2 sound problem; however, I think the two are related.

Message One:

I've got a Dell 2400 running the latest kernel for FC3 as well as all
of the latest updates, and a Dell 4550 running the latest FC2 kernel
and other software updates. The strange thing is, that each computer
worked flawlessly with the first few kernels for the respective FC
releases (FC2 and FC3). And this included the sound--it worked great.
Now, with the last few kernels the sound card simply stopped working.
The cards are detected when I run the SoundCard detection, but when I
do something that would generate a sound--nothing.

Thanks,
Richard Huelbig

Message Two:

Here are some additional details:

FC2 is running on a Dell Dimension 4550 with an integrated sound card
(the spec says it uses a 1981A codec).
FC3 is running on a Dell Dimension 2400 with an integrated sound card
(no information as to the codec).

FC2 kernels that don't work on the Dimension 4550 are: 2.6.10-1.9_FC2
and 2.6.10-1.8_FC2.
FC2 kernels that work on the 4550 are: 2.6.9-1.11_FC2 and earlier.

FC3 kernels that don't work on the Dimension 2400 are:
2.6.10-1.741_FC3 and 2.6.10-1.737_FC3.
FC3 kernels that work on the 2400 are: 2.6.9-1.724_FC3 and earlier.

On both machines I'm running Gnome desktop, not KDE. The FC2 PC is
using Gnome 2.6. The FC3 PC is using Gnome 2.8.0. I do not know if my
sound is running under OSS, ALSA, or ESD; I'm not sure what these
abbreviations mean or how to determine which is used.

Regarding the sounds drivers, when I use the System Settings/Soundcard
Detection tool I get the following information:

For the FC2 machine:
Intel Corp., 82801DB(KH4) AC'97 Audio Controller, snd-intel8x0

For the FC3 machine:
Intel Corp., 82801DB/DBL/DBM(ICH4/ICH4-L/ICH4-M) AC'97 Audio
Controller, snd-intel8x0

Thanks,
Richard Huelbig

Message 3:

When I went over to Bugzilla I did a search on some sound card
problems and upgrading kernels. In Bugzilla I found a workaround for
my FC3 machine. I opened the volume control and set the Headphone Jack
Sense and Line Jack Sense settings to Mute (I checked the Mute check
boxes). When I did that I started to get sound.

However, on my FC2 PC, when I open the volume control I do not have
Line Jack Sense and Headphone Jack Sense selections. So, my problem
remains with the latest kernel and FC2. I will post these findings on
Bugzilla. If anyone has any additional information, please share it.

Thanks,
Richard Huelbig


Version-Release number of selected component (if applicable):
2.6.10-1.8_FC2 and 2.6.10-1.9_FC2

How reproducible:
Always

Steps to Reproduce:
For FC2 Problem:

1. Run kernel 2.6.9-1.11_FC2.
2. Test for sound card detection--passes--sound produced.
3. Run kernel 2.6.10-1.8_FC2 or 2.6.10-1.9_FC2.
4. Repeat step 2--fails--no sound produced.
5. No workaround known at this time.

For FC3 Problem:

1. Run kernel 2.6.9-1.724_FC3.
2. Test for sound card detection--passes--sound produced.
3. Run kernel 2.6.10-1.737_FC3 or 2.6.10-1.741_FC3.
4. Repeat step 2--fails--no sound produced.
5. Open the volume control and set Headphone Jack Sense and Line Jack
Sense settings to Mute.
6. Repeat step 2T--passes--sound produced.


    
    

Actual Results:  Please see notations in the Description section and
the Steps To Reproduce section.

Expected Results:  Should hear sound when testing for soundcard.

Additional info:

This information has also been posted to the Fedora Forum web site.
Comment 1 Richard Huelbig 2005-01-24 21:50:57 EST
Hello Bugzilla folks. Figured I would update you on what I've found out.

Okay, here's the trick.

With FC3 you've got to open the volume control and mute the Line Jack
Sense and Headphone Jack Sense settings.

With FC2 these settings don't show up in the volume control. So, run
the command "alsamixer", as root, from a terminal window. The volume
control that appears in the terminal window will have the two missing
settings. Use the left/right arrow keys to select the appropriate
slider and the press Shift-M (for mute). You'll notice in the
upper-left corner the name of the slider and whether or not it's muted
(off).

Hope this helps.. Thanks to all on this forum for your suggestions and
for other, related and helpful posts. I'll also post this information
into my Bugzilla incident.

Regards,

Richard Huelbig

P.S. I've attached a .PNG file of the two volume controls (Gnome
versus alsamixer) in the Fedora Forum. I couldn't attach a .PNG file here.
Comment 2 Warren Togami 2005-01-24 22:10:59 EST

*** This bug has been marked as a duplicate of 144742 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.