Bug 1458734 - [RGW]: After failover and failback on a multisite setup, period mismatch on both sites seen.
Summary: [RGW]: After failover and failback on a multisite setup, period mismatch on b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.3
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: rc
: 2.3
Assignee: Casey Bodley
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-05 11:08 UTC by Tejas
Modified: 2017-07-30 15:56 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.7-27.el7cp Ubuntu: ceph_10.2.7-29redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-19 13:33:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 18639 0 None None None 2017-06-05 20:32:41 UTC
Red Hat Product Errata RHBA-2017:1497 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Tejas 2017-06-05 11:08:33 UTC
Description of problem:

    On a 2 site setup, I did a failover and failback scenario, with the command exactly as described in the doc:
https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/2/html-single/object_gateway_guide_for_red_hat_enterprise_linux/#configuring_a_master_zone

Version-Release number of selected component (if applicable):
ceph version 10.2.7-26redhat1xenial

How reproducible:


Steps to Reproduce:
1. Create a couple of buckets on both sites to check if they are working fine.
2. Bring down primary(site A), do a zone modify on site B to make it the master.
Do a period update commit and restart radosgw.
3. Create a new bucket on site B, while A is down.
4. Bring back site A, do a period pull from site B, and do period update commit and restart radosgw on site A.
5. Check the sync status on site B, a period mismatch is seen.


I will enable the logs and provide the system details.

Comment 5 Ian Colle 2017-06-05 15:24:02 UTC
Was this same behavior seen on rhel?

Comment 18 Rachana Patel 2017-06-12 16:02:29 UTC
verified with latest version(container) and it worked for container hence moving to verified state

Comment 20 errata-xmlrpc 2017-06-19 13:33:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.