Bug 145882 - gcc >= 3.3 deprecated multi-line asm breaks test for assembler
gcc >= 3.3 deprecated multi-line asm breaks test for assembler
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lzo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
http://bugs.gentoo.org/show_bug.cgi?i...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-22 23:52 EST by Arenas Belon, Carlo Marcelo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 16:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for configure.in to fix the assembler tests (738 bytes, patch)
2005-01-22 23:54 EST, Arenas Belon, Carlo Marcelo
no flags Details | Diff

  None (edit)
Description Arenas Belon, Carlo Marcelo 2005-01-22 23:52:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
patch applies to macros for configure.in and will require that
configure be recreated (autoconf).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. tar -xvzf lzo-1.08.tar.gz
2. cd lzo-1.08
3. ./configure

Actual Results:  checking the alignment of the assembler... 0
checking whether to build assembler versions... no

Expected Results:  checking the alignment of the assembler... 4
checking wheter global symbols need underscores... no
checking wheter the assembler understands .type... yes
checking wheter the assembler works... yes
checking wheter to build assembler versions... yes

Additional info:

the only "affected" architecture should be i386 as it is the only one
which currently has assembler code which could be used, eventhough all
architectures fail to detect the working assembler because of the
broken test.

fc3 has no workaround, for all others using the old compiler (from the
compat packages) could be considered as a workaround.
Comment 1 Arenas Belon, Carlo Marcelo 2005-01-22 23:54:33 EST
Created attachment 110100 [details]
patch for configure.in to fix the assembler tests
Comment 2 Matthias Saou 2005-02-01 07:15:14 EST
I can confirm that this patch fixes the assembler detection on i386,
and the package then builds fine with asm enabled on x86, and still
builds fine (with asm disabled) on x86_64.
Comment 3 Hans de Goede 2006-07-25 16:00:19 EDT
I'm taking over as maintainer from Anvil, since Anvil has other priorities.

Thanks for the patch.

1.08-7 should show up on a mirror near you soon, containing a modified version
of your patch, fixing this. The changes in 1.08-7 are:
* Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
- Taking over as maintainer since Anvil has other priorities
- Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
  Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
- Removed unused build dependency on nasm
- Remove static lib
- Cleanup %doc a bit


Note You need to log in before you can comment on or make changes to this bug.