Bug 1458937 - [RFE] Add example kickstarts for 32bit UEFI support to livemedia-creator
Summary: [RFE] Add example kickstarts for 32bit UEFI support to livemedia-creator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lorax
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
Petr Bokoc
URL:
Whiteboard:
Depends On: 1523688
Blocks: 1392968 1478303
TreeView+ depends on / blocked
 
Reported: 2017-06-05 21:32 UTC by Brian Lane
Modified: 2018-04-10 17:39 UTC (History)
10 users (show)

Fixed In Version: lorax-19.6.95-1.el7
Doc Type: Enhancement
Doc Text:
The *livemedia-creator* utility now provides a sample Kickstart file for UEFI systems The example Kickstart files provided with the _livemedia-creator_ packages have been updated to support 32 and 64-bit UEFI systems. The files are located in the `/usr/share/lorax-version/` directory. Note that *livemedia-creator* must be run on a UEFI system or virtual machine to build bootable UEFI disk images.
Clone Of:
: 1488429 (view as bug list)
Environment:
Last Closed: 2018-04-10 17:38:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
Example kickstart for 32/64 bit UEFI on x86 (1.19 KB, text/plain)
2017-06-05 21:35 UTC, Brian Lane
no flags Details
patch_to_add_package (1.09 KB, patch)
2017-06-26 14:48 UTC, Marek Hruscak
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0947 None None None 2018-04-10 17:39:16 UTC

Description Brian Lane 2017-06-05 21:32:21 UTC
32bit UEFI booting needs different packages on each arch, we need to add and test new examples for UEFI64/32 on x86_64, aarch64, and ppc64

Comment 2 Brian Lane 2017-06-05 21:35:40 UTC
Created attachment 1285163 [details]
Example kickstart for 32/64 bit UEFI on x86

Comment 3 Brian Lane 2017-06-05 21:42:15 UTC
I've tested this kickstart with x86_64 and qemu UEFI and it works fine. I don't have any way to test 32bit booting.

I added the following for x86:

grub2-tools-efi
shim-x64
grub2-efi-x64-cdboot
efibootmgr
shim-ia32
grub2-efi-ia32-cdboot


aarch64 should, I think, add:

efibootmgr
grub2-efi-aa64-cdboot
grubby
shim-aa64


ppc64 should be:

grub2-tools
grub2-tools-minimal
grub2-tools-extra
grub2-ppc64

ppc64le should be:

grub2-tools
grub2-tools-minimal
grub2-tools-extra
grub2-ppc64le

Comment 5 Brian Lane 2017-06-13 16:15:45 UTC
*** Bug 1460499 has been marked as a duplicate of this bug. ***

Comment 8 Brian Lane 2017-06-15 17:29:06 UTC
Changes are smaller than I expected:

https://github.com/rhinstaller/lorax/pull/216

Comment 11 Marek Hruscak 2017-06-26 14:46:46 UTC
Example kickstart is missing package grub2-efi-ia32 . System is unable to boot without it. Tested with no-virt option both make-disk with rhel7-minimal.ks and make-iso with rhel7-livemedia.ks .
Adding mentioned package manually makes both .iso and .img bootable.
Legacy grub2-efi in %packages is provided by grub2-efi-x64 , but not with grub2-efi-ia32 , which is not installed.
I have tested both output from make-iso and make-disk .img on both x64(KVM VM) and ia32(Minnowboard Turbot) firmwares. With added package grub2-efi-ia32 it works fine.
Patch in attachment.

Comment 12 Marek Hruscak 2017-06-26 14:48:00 UTC
Created attachment 1292006 [details]
patch_to_add_package

Comment 20 Marek Hruscak 2018-02-06 10:05:09 UTC
Verified on RHEL-7.5-20180201.2 with lorax-19.6.104-1 .

Lorax now contains rhel7-livemedia/minimal.ks with correct packageset
Live .iso is able to boot without problem on 32bit UEFI firmware. All needed packages are installed.

Comment 23 errata-xmlrpc 2018-04-10 17:38:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0947


Note You need to log in before you can comment on or make changes to this bug.