Bug 1459015 - When keep_time_key is missing in in_tail fluentd plugin the records are sent with no timestamp
When keep_time_key is missing in in_tail fluentd plugin the records are sent ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic (Show other bugs)
1.0.3
Unspecified Unspecified
unspecified Severity unspecified
: ovirt-4.1.3
: 1.0.4.1
Assigned To: Shirly Radco
Lukas Svaty
:
Depends On:
Blocks: oVirt-Metrics-and-Logs 1456459
  Show dependency treegraph
 
Reported: 2017-06-06 02:59 EDT by Shirly Radco
Modified: 2017-07-06 09:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 09:12:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 77837 master MERGED fluentd: added keep_time_key to the logs parser 2017-06-06 03:12 EDT

  None (edit)
Description Shirly Radco 2017-06-06 02:59:51 EDT
Description of problem:
The in_tail plugin is configured to drop the time field from the record unless we add "keep_time_key  true" parameter.

Version-Release number of selected component (if applicable):
1.0.3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
Records are missing time field and because of it are rejected from the metrics store.

Expected results:
All records should include time field.

Additional info:
Comment 1 Lukas Svaty 2017-06-22 05:56:14 EDT
ovirt-engine-metrics-1.0.4.2-1.el7ev.noarch records available in kibana, thus have timestamp correctly set up

Note You need to log in before you can comment on or make changes to this bug.