Bug 1459051 - disable-multipath script should not disable & stop multipathd
Summary: disable-multipath script should not disable & stop multipathd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.3.0
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-3 1417151 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-06-06 07:55 UTC by SATHEESARAN
Modified: 2017-09-21 04:49 UTC (History)
5 users (show)

Fixed In Version: gdeploy-2.0.2-11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-21 04:49:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2777 normal SHIPPED_LIVE gdeploy bug fix and enhancement update for RHEL7 2017-09-21 08:23:08 UTC

Description SATHEESARAN 2017-06-06 07:55:41 UTC
Description of problem:
-----------------------
The script that gdeploy uses to blacklist the devices, stops & disabled multipathd.
This script is expected **only** to blacklist the local devices

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.1-13.el7rhgs
gdeploy-2.0.2-10.el7rhgs

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Run 'disable-multipath.sh'

Actual results:
---------------
multipathd is stopped and disabled

Expected results:
-----------------
multipathd should not be stopped and disabled

Additional info:
----------------
# cat /usr/share/ansible/gdeploy/scripts/disable-multipath.sh 
#!/usr/bin/env bash

multipath -F
cat <<EOF>> /etc/multipath.conf
blacklist {
        devnode "*"
}
EOF

systemctl stop multipathd
systemctl disable multipathd

Comment 1 SATHEESARAN 2017-06-06 07:59:44 UTC
Also the name of the script should be changed from 'disable_multipath.sh' to 'blacklist_all_disks.sh', otherwise this is going to misleading the users

Comment 4 Sachidananda Urs 2017-06-16 07:21:13 UTC
Commit: https://github.com/gluster/gdeploy/commit/9adca82 should fix the issue.

Comment 5 SATHEESARAN 2017-07-11 10:56:32 UTC
Tested with gdeploy-2.0.2-12.el7rhgs

The script 'disable_multipath.sh' doesn't disables and stops multipathd.
Also the script is now renamed to 'blacklist_all_disks.sh'

Comment 8 errata-xmlrpc 2017-09-21 04:49:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2777


Note You need to log in before you can comment on or make changes to this bug.