Bug 1459078 - SELinux is preventing login from using the 'dac_read_search' capabilities.
SELinux is preventing login from using the 'dac_read_search' capabilities.
Status: CLOSED DUPLICATE of bug 1459081
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:6161aa60f685f3f3cb0f6e0e3d3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 04:54 EDT by Bruno Javier Blasco Smaranda
Modified: 2017-06-06 07:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-06 07:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Javier Blasco Smaranda 2017-06-06 04:54:41 EDT
Description of problem:
This is a fresh rawhide installation upgraded by dnf plugin from a fresh f25 installation.
I was told in IRC the events are due to a kernel change where the order of dac_read_search and dac_override changed to fix check dac_read_search
SELinux is preventing login from using the 'dac_read_search' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that login should have the dac_read_search capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'login' --raw | audit2allow -M my-login
# semodule -X 300 -i my-login.pp

Additional Information:
Source Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Context                system_u:system_r:local_login_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        login
Source Path                   login
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-255.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.12.0-0.rc3.git0.2.fc27.x86_64 #1
                              SMP Tue May 30 19:36:51 UTC 2017 x86_64 x86_64
Alert Count                   1
First Seen                    2017-06-05 21:40:47 CEST
Last Seen                     2017-06-05 21:40:47 CEST
Local ID                      955c23f4-1986-4c56-9856-ecccd299043b

Raw Audit Messages
type=AVC msg=audit(1496691647.830:1515): avc:  denied  { dac_read_search } for  pid=11580 comm="login" capability=2  scontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tcontext=system_u:system_r:local_login_t:s0-s0:c0.c1023 tclass=capability permissive=0


Hash: login,local_login_t,local_login_t,capability,dac_read_search

Version-Release number of selected component:
selinux-policy-3.13.1-255.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.12.0-0.rc3.git0.2.fc27.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2017-06-06 07:52:12 EDT

*** This bug has been marked as a duplicate of bug 1459081 ***

Note You need to log in before you can comment on or make changes to this bug.