Bug 1459083 - Logging in using SAML uses the wrong email (alias)
Logging in using SAML uses the wrong email (alias)
Status: CLOSED DUPLICATE of bug 1351859
Product: Bugzilla
Classification: Community
Component: User Accounts (Show other bugs)
5.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 05:06 EDT by Nils Philippsen
Modified: 2017-06-14 23:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-14 23:17:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2017-06-06 05:06:28 EDT
Description of problem:
When logging in as "Red Hat Associate", it seems to be using my current Kerberos token and then logs me in as "nils@redhat.com", but my account on Bugzilla is "nphilipp@redhat.com".

Version-Release number of selected component (if applicable):
version 5.0.3.rh29

How reproducible:
Reproducible.

Steps to Reproduce:
0. [Have my Kerberos ticket]
1. Go to https://beta-bugzilla.redhat.com/
2. Click "Login", then "Red Hat Associate"
3. Click "My Links → My Bugs"

Actual results:
I am logged in as "nils@redhat.com", the bug list is empty because it searches for the wrong Bugzilla account.

Expected results:
I am logged in as "nphilipp@redhat.com" (my existing BZ account) and I see a handful of open bugs assigned to me.

Additional info:
Comment 1 Jeff Fearn 2017-06-06 18:32:12 EDT
It uses the mail address returned by the SSO server, if you want to change that you need to change your preferred email address in LDAP. AIUI the only way to do this is to email the service desk and ask them to change it.

There is also Bug 1351859 but that isn't on the current schedule due to resource constraints :(
Comment 2 Jeff Fearn 2017-06-14 23:17:15 EDT
Closing a as dupe of 1351859. Note you can get your mail changed in ldap by emailing service desk and requesting it.

*** This bug has been marked as a duplicate of bug 1351859 ***

Note You need to log in before you can comment on or make changes to this bug.