Bug 1459085 - The source URL should be updated for libpng
The source URL should be updated for libpng
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libpng12 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Forró
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 05:07 EDT by Nikola Forró
Modified: 2017-06-06 05:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: libpng12-1.2.57-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1458040
Environment:
Last Closed: 2017-06-06 05:44:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Forró 2017-06-06 05:07:06 EDT
+++ This bug was initially created as a clone of Bug #1458040 +++

Glenn Randers-Pehrson filed an issue with Anitya[0] about updating the source URLs for libpng projects and I thought I would bring this to the packagers attention as well. Apparently upstream tarballs are now available via HTTPS (rather than FTP) at:

https://ftp-osl.osuosl.org/pub/libpng/src/libpng10/
https://ftp-osl.osuosl.org/pub/libpng/src/libpng12/
https://ftp-osl.osuosl.org/pub/libpng/src/libpng15/
https://ftp-osl.osuosl.org/pub/libpng/src/libpng16/
https://ftp-osl.osuosl.org/pub/libpng/src/beta/libpng17/

Or directly from GitHub tags. Apparently the old FTP system is quite overloaded and using a slow DSL connection.

This affects this package, as well as libpng10, libpng12, and libpng15. It looks like it's pretty much the same set of maintainers so I thought I'd start with just the one bug, but I'm happy to duplicate it if the maintainers wish it.

Thanks!

[0] https://github.com/release-monitoring/anitya/issues/489

Note You need to log in before you can comment on or make changes to this bug.