Bug 1459119 - Error: Field 'smart_proxy+' not recognized for searching! when listing hosts from capsule overview page
Error: Field 'smart_proxy+' not recognized for searching! when listing hosts ...
Status: CLOSED DUPLICATE of bug 1408555
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.2.9
x86_64 Linux
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 06:57 EDT by Sam Wachira
Modified: 2017-08-03 07:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1339672
Environment:
Last Closed: 2017-06-06 07:13:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hosts managed link to click (20.54 KB, image/png)
2017-06-06 06:57 EDT, Sam Wachira
no flags Details
Error displayed after clicking on link (24.54 KB, image/png)
2017-06-06 06:58 EDT, Sam Wachira
no flags Details

  None (edit)
Description Sam Wachira 2017-06-06 06:57:02 EDT
Created attachment 1285340 [details]
Hosts managed link to click

+++ This bug was initially created as a clone of Bug #1339672. Similar issue is discussed in Bug #1408555 +++


Description of problem:
After clicking infrastructure > capsules and choosing the internal or any external capsule under "overview" and "puppet ca" you can see the number of hosts that are "managed" by the specific capsule.

However after clicking the hosts managed hyperlink this takes you to "all hosts" and they are not filtered.


Steps to Reproduce:
In Sat 6.2.9 UI, go to Infrastructure > Capsules and select a capsule. On the Overview tab click the number next to "Hosts managed".
You are taken to the Hosts and the following error is displayed:


Actual results: 
Error: Field 'smart_proxy+' not recognized for searching!

All hosts on Satellite are displayed instead of filtered list of hosts managed by the capsule. Query appears as follows.
smart_proxy+=+"capsulehostname.example.com"


Expected results:
Only hosts managed by capsule should be displayed.
If you remove "+" signs from the query, it returns expected results.
Comment 1 Sam Wachira 2017-06-06 06:58 EDT
Created attachment 1285341 [details]
Error displayed after clicking on link
Comment 2 Tomer Brisker 2017-06-06 07:13:46 EDT
Looks like BZ 1408555 was mistakenly marked as closed, closing this issue as a duplicate of that. Thank you for your report!

*** This bug has been marked as a duplicate of bug 1408555 ***

Note You need to log in before you can comment on or make changes to this bug.