Bug 1459188 - The manageiq.api_token seems only to be valid on a single appliance setup.
The manageiq.api_token seems only to be valid on a single appliance setup.
Status: CLOSED DUPLICATE of bug 1459674
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: -- Unknown (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: cfme-future
Assigned To: John Hardy
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 09:34 EDT by ldomb
Modified: 2017-12-05 10:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-12 16:38:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ldomb 2017-06-06 09:34:55 EDT
Description of problem:
The variable manageiq.api_token seems only to be valid on a single appliance setup. On a multi appliance setup the token is invalid. 

Version-Release number of selected component (if applicable):
5.8.0.17.20170525183055_6317a22

How reproducible:


Steps to Reproduce:
1. Create a repository out of https://github.com/mkanoor/playbook.git
2. Create a service dialog from provider_refresh.yml
3. Run this in a single appliance setup with the ansible and the token is valid. Run this in a multi appliance setup where the ansible role is enabled but not on the UI appliance the token is called invalid

Actual results:
token is invalid

Expected results:
token is valid

Additional info:
Comment 2 Dave Johnson 2017-06-12 16:38:59 EDT
Tim, please confirm this is a duplicate and reopen if not.

*** This bug has been marked as a duplicate of bug 1459674 ***
Comment 3 Tim Wade 2017-06-12 16:56:10 EDT
Dave,

Yep, looks like the same bug to me.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.