Bug 1459199 - Fence agent for VMWare cannot login when certificate is self-signed
Fence agent for VMWare cannot login when certificate is self-signed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Oyvind Albrigtsen
Chris Mackowski
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 10:07 EDT by Marek Grac
Modified: 2017-08-01 12:10 EDT (History)
5 users (show)

See Also:
Fixed In Version: fence-agents-4.0.11-64.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2017-06-06 10:07:54 EDT
Due to the changes in python/ssl modules it is no longer possible to login to VMWare.

Following code has to be added:

import ssl
if hasattr(ssl, '_create_unverified_context'):
  ssl._create_default_https_context = ssl._create_unverified_context
Comment 4 Marek Grac 2017-06-06 10:18:39 EDT
Similar issue was already solved in pcs (upstream)

https://github.com/ClusterLabs/pcs/commit/3b01c8d50df599301d9d7adb66fe2b037a12d25e
Comment 5 Marek Grac 2017-06-06 10:37:46 EDT
Source of the problem should be here:

https://bugzilla.redhat.com/show_bug.cgi?id=1219110#c9
Comment 7 Oyvind Albrigtsen 2017-06-07 03:36:11 EDT
Patch: https://github.com/ClusterLabs/fence-agents/pull/119
Comment 10 errata-xmlrpc 2017-08-01 12:10:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1874

Note You need to log in before you can comment on or make changes to this bug.